2

I am on an Ubuntu 16.04 64bit using an AMD radeon r9 390 gpu

Recently I had installed the "amd gpu-pro-17.10" driver and had Vulkan working, and I could play Dota 2 with better performance than in Windows.

But running World of Warcraft 7.3 I had a little low fps in raids.

I decided to try out the The mesa graphics driver with Gallium Nine support, which WineHQ recommends for WoW.

Important part!!! I uninstalled "amd gpu-pro" driver.

Then I installed "oibaf graphics driver", following this tutorial https://wiki.ixit.cz/d3d9_tutorial

Rebooted, and now Vulkan isn't working.

I can't really find any help to enable vulkan for this new graphics driver.

Vulkan API Version: 1.0.61

INFO: [loader] Code 0 : Found manifest file /home/simon/vulkan/VulkanSDK/1.0.61.1/x86_64/etc/explicit_layer.d/VkLayer_monitor.json, version "1.0.0"
INFO: [loader] Code 0 : Found manifest file /home/simon/vulkan/VulkanSDK/1.0.61.1/x86_64/etc/explicit_layer.d/VkLayer_standard_validation.json, version "1.1.1"
INFO: [loader] Code 0 : Encountered meta-layer VK_LAYER_LUNARG_standard_validation
INFO: [loader] Code 0 : Found manifest file /home/simon/vulkan/VulkanSDK/1.0.61.1/x86_64/etc/explicit_layer.d/VkLayer_object_tracker.json, version "1.1.0"
INFO: [loader] Code 0 : Found manifest file /home/simon/vulkan/VulkanSDK/1.0.61.1/x86_64/etc/explicit_layer.d/VkLayer_screenshot.json, version "1.0.0"
INFO: [loader] Code 0 : Found manifest file /home/simon/vulkan/VulkanSDK/1.0.61.1/x86_64/etc/explicit_layer.d/VkLayer_unique_objects.json, version "1.1.0"
INFO: [loader] Code 0 : Found manifest file /home/simon/vulkan/VulkanSDK/1.0.61.1/x86_64/etc/explicit_layer.d/VkLayer_threading.json, version "1.1.0"
INFO: [loader] Code 0 : Found manifest file /home/simon/vulkan/VulkanSDK/1.0.61.1/x86_64/etc/explicit_layer.d/VkLayer_api_dump.json, version "1.0.0"
INFO: [loader] Code 0 : Found manifest file /home/simon/vulkan/VulkanSDK/1.0.61.1/x86_64/etc/explicit_layer.d/VkLayer_vktrace_layer.json, version "1.0.0"
INFO: [loader] Code 0 : Found manifest file /home/simon/vulkan/VulkanSDK/1.0.61.1/x86_64/etc/explicit_layer.d/VkLayer_parameter_validation.json, version "1.1.0"
INFO: [loader] Code 0 : Found manifest file /home/simon/vulkan/VulkanSDK/1.0.61.1/x86_64/etc/explicit_layer.d/VkLayer_core_validation.json, version "1.1.0"
INFO: [loader] Code 0 : Found manifest file /home/simon/vulkan/VulkanSDK/1.0.61.1/x86_64/etc/explicit_layer.d/VkLayer_device_simulation.json, version "1.1.0"
INFO: [loader] Code 0 : Found manifest file /home/simon/.local/share/vulkan/implicit_layer.d/steamoverlay_i386.json, version "1.0.0"
INFO: [loader] Code 0 : Found manifest file /home/simon/.local/share/vulkan/implicit_layer.d/steamoverlay_x86_64.json, version "1.0.0"
INFO: [loader] Code 0 : Meta-layer VK_LAYER_LUNARG_standard_validation all 5 component layers appear to be valid.
Cannot create Vulkan instance.
/tmp/SDK-DEV/Build/Vulkan-LoaderAndValidationLayers/demos/vulkaninfo.c:698: failed with VK_ERROR_INCOMPATIBLE_DRIVER

1 Answer 1

0

Take a look at these two files:

/usr/share/vulkan/icd.d/radeon_icd.i686.json
/usr/share/vulkan/icd.d/radeon_icd.x86_64.json

They should look something like:

/usr/share/vulkan/icd.d/radeon_icd.i686.json

{
    "file_format_version" : "1.0.0",
    "ICD": {
        "library_path": "/usr/lib32/libvulkan_radeon.so",
        "api_version" : "1.0.49"
    }
}

/usr/share/vulkan/icd.d/radeon_icd.x86_64.json

{
    "file_format_version" : "1.0.0",
    "ICD": {
        "library_path": "/usr/lib/libvulkan_radeon.so",
        "api_version" : "1.0.49"
    }
}

If not you can modify them for a quickfix, and please report as a packaging bug if this fixes your issue.

I don't own an AMD card, but spoke with a kind soul to find out the proper library should be as this is a known issue with some nvidia packages already.

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .