6

Finished the upgrade last night, logged into a black desktop. The launch bar and top bar is there and working, and everything else in the system works as normal.

I was able to specify a wallpaper file in settings and it displays, but still no icons, no action if I right-click on the desktop. There's just nothing there.

Any ideas of things to try?

Screenshot

4
  • 1
    Are you in Unity or in GNOME? Unity is no longer supported and was replaced by GNOME in 17.10. Please post a screenshot. I think under GNOME there are no icons on the background any more. – dobey Oct 20 '17 at 14:23
  • Added i.stack.imgur.com/8BfeH.png screenshot. – DFarmerTX Oct 20 '17 at 18:48
  • Huh, that's Unity. How weird. What version did you upgrade from? – wjandrea Oct 20 '17 at 19:03
  • This was upgraded from 17.04. I selected "Unity" from the login options. – DFarmerTX Oct 20 '17 at 19:28
4

If you are using Gnome install gnome-tweak-tool and make sure that Show Icons is set under Desktop.enter image description here

If you are still using Unity, you can use the Terminal to do this:

gsettings set org.gnome.desktop.background show-desktop-icons true

6
  • Hi, that tool is shown in the original screenshot, those settings are already in place. – DFarmerTX Oct 22 '17 at 14:50
  • Hey. Didn't see that screenshot before. Check out my updated answer. – mniess Oct 23 '17 at 11:33
  • Thanks for the update, yes, these settings are one of the first things I tried. The desktop is nothing, there's no response, no right-click, nothing. Still no icons. – DFarmerTX Oct 23 '17 at 14:12
  • @DFarmerTX Have you tried opening nautilus? If the icons don't display then, you seem to be experiencing a bug. – mniess Oct 23 '17 at 14:24
  • Hi, nautilus works fine, I can open my desktop folder and see my launcher icons. There's just nothing where the desktop is supposed to be. I'll dig though the syslog and see what its saying. – DFarmerTX Oct 23 '17 at 21:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.