48

Just moved from Unity to GNOME with the update to Ubuntu 17.10. There is a HUGE amount of wasted space at the top of the screen, when an application is open.

Evolution and Firefox both have four "bars" with 90% of each empty. Unity, to its credit was able to blend / mix these horizontal bars so there was only one / two.

Four is way too much. If this is GNOME I may carry on with Unity for the next six months.

Can anybody suggest a tweak/change/fix for this?

  • 7
    There is nothing like Unity for efficient screen space utilization. ...and welcome to Gnome 3. :~) – mikewhatever Oct 20 '17 at 11:15
  • 1
    Thanks MIke...... I have a feeling that I may be going back to Unity sometime soon. I'll give it a week or so and see if I can live witht he huge amount of wasted screen space.... Cheerio. – Piloti Oct 20 '17 at 11:45
  • 5
    100% agree. THIS is the reason for me to stay with 16.04 until EOL or eventually switch to Cinnamon. The top bar in Gnome3 is so ugly and totally not useful. And I don't know why only few people complain. There are extensions to partially fix that (best is imho Unite). But like I said only partially and they always have problems with consistency. – RoVo Oct 20 '17 at 12:52
  • 2
    Unfortunately, you have discovered one of the most reviled aspects of GNOME. desktop. It has been around for quite a while. And, no one has a fix for it yet. Sticking with 17.04 for now. – Orian Oct 20 '17 at 12:52
  • I could of course also install unity7 alongside gnome-shell instead of staying with 16.04 ... But as it is an abandoned project, I'm not sure about that. – RoVo Oct 20 '17 at 13:10
35

You may try one of following GNOME shell extensions:

  • No Title Bar (an actively maintained fork of Pixel Saver with customisation options)

    No Title Bar removes the title bar, moves the window title and buttons to the top panel.

  • Pixel Saver

    Pixel Saver is designed to save pixel by fusing activity bar and title bar in a natural way.

    Note that Pixel Saver is not actively maintained anymore, therefore has a lot of unresolved issues like this one and doesn't offer any customisation options.


You can even go further and hide the top bar following this answer by solsTiCe from this Q&A: Auto hiding top panel in 17.10 GNOME 3.26.1

Also, you may move the menu bar from an application window to the top-bar ("Activities bar") following this Q&A: Ubuntu 17.10 windows' menu in panel

  • 2
    Done it. No Title Bar. Brilliant. Thanks – Piloti Oct 20 '17 at 14:38
  • 1
    Just did have a look at it, while it removes the title bar, on a multi monitor system with having only the top bar at one screen, its kinda unintuitive which window the close button etc belongs to. otherwise it works as intended – Videonauth Oct 22 '17 at 18:38
  • 1
    You can go even further and try Hide top bar to gain even more pxiels. – solsTiCe Oct 23 '17 at 16:40
  • 1
    yes. It's not perfect but it does the job! – solsTiCe Oct 23 '17 at 17:00
  • 1
    doesn't work for me with latest ubuntu 18.04 – shivshankar Apr 28 '18 at 12:15
3

In answer to the questions "what did I do....?", in the end, I went back to Unity and actually took the opportunity to start again with a fresh install of 16.04LTS; including of course Unity. Happy as a sandpiper.

2

I recommend going back to Unity

$ sudo apt update
$ sudo apt install ubuntu-unity-desktop

Choose ligthdm

However I have the feeling that some information is not available in unity.

On gnome I did see many things under power setting :/

0

I prefer the Unite GNOME Shell Extension. It manages to integrate far more application windows into the top bar than No Title Bar or Pixel Saver does.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.