22

I used the upgrade manager to upgrade from 17.04 to 17.10. When I start the machine, I only get a black flickering screen now. I was using the nvidia binary drivers before the upgrade.

NOTE: This question (and answer) relate to a specific issue when upgrading from 17.04 to 17.10 while using Nvidia or AMD binary drivers. You might experience a completely different issue. For that please see the more general question My computer boots to a black screen, what options do I have to fix it?.

0
23

This happened to several users of NVidia or AMD binary drivers (Bug #1705369). You need to re-install the drivers:

  1. Switch to a different terminal (TTY) by pressing CTRL+ALT+F2 and login with your user.
  2. Remove the binary driver by running sudo apt-get purge ^nvidia. AMD users can run amdgpu-pro-uninstall to remove the AMD graphics stack.
  3. If /etc/X11/xorg.conf exists, rename (e.g. sudo mv /etc/X11/xorg.conf{,.bak}).
  4. Disable Wayland completely: edit /etc/gdm3/custom.conf and uncomment the following line # WaylandEnable=false
  5. Reboot Ubuntu with sudo shutdown -r now and you should see the login screen.

You can now install your binary drivers again, either manually (see How do I install the Nvidia drivers) or with the Software Properties GUI. AMD users should refer to the official installation guide for instructions.

After rebooting everything should work as expected.

Note: The new Wayland display server doesn't work with binary drivers, yet, which is why we disabled it in step 4. In the future, when Wayland is fully supported by the binary drivers, you should comment this line again.

12
  • 4
    Thanks. It's ridiculous how frequently Ubuntu updates result in me seeing a black screen. There needs to be much better support with Nvidia cards. – Ben Watson Oct 21 '17 at 15:12
  • 1
    In this case is not a problem, but that purge command should be apt-get purge '^nvidia'. apt suite uses regular expressions, not globbing. See askubuntu.com/questions/210976/… , especially Eliah Kagan answer. – Rmano Oct 24 '17 at 17:25
  • Unfortunately it is not a working solution for most of us :( – user149760 Dec 29 '17 at 17:20
  • @Randomize As question and answer state: This is on a specific issue that happens when upgrading to 17.10 while using proprietary drivers. For that sepecific issue, this is the solution. For general black screen trouble-shooting please see the link in the question. – mniess Jan 2 '18 at 10:40
  • @mniess I don't see the difference at all. If you want to something really working for that issue check this: gist.github.com/wangruohui/df039f0dc434d6486f5d4d098aa52d07 – user149760 Jan 2 '18 at 10:45
0

I had the same problem and reportet a bug already (Bug #1725169). In my case I could locate it to the lowlatency-kernel, that was installed during upgrade without beeing asked. Unfortunately it was the first kernel in grub. Deinstalling this Kernel solved the problem. No need for reinstalling the nvidia-drivers.

1
  • 1
    Welcome to Ask Ubuntu! I recommend to edit this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) – David Foerster Nov 13 '17 at 19:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.