20

I have downloaded Ubuntu 17.10 recently, and I found out that if you move the cursor on the top bar the mouse is starting to lag. (especially if you open one of the tabs on the top bar, and then move you mouse across the bar).

I thought that's the only problem with the mouse, but then when I opened a game that is working on OPEN-GL, the mouse just didn't stop lagging, of course, when I closed the game, the mouse was working ok. (by the way, it happend with every steam game).

I was looking for an answer, but all I found is this solution How can I get rid of mouse lag under Ubuntu?.

It did not happen when I used Ubuntu 17.04.

I have Intel Core i5-6198DU CPU @ 2.30GHz x 4, Intel HD Graphics 510(Skylake GT1), GNOME 3.26.1, 64-bit.

Can you please help me find a solution? Thank you very much :)

  • So let me ask this you have mouse lag happen in 17.10 which did not happen as you used 17.10? Confuses me :) – Videonauth Oct 20 '17 at 9:12
  • @Videonauth I am really sorry i'll fix it right now – Argaman Oct 20 '17 at 9:28
  • Don't worry, just thought I'd let you know and simply assuming that it is meant to be 17.04 was a bit far fetched for doing the edit myself. :) – Videonauth Oct 20 '17 at 9:31
21

"Gnome/Wayland has mouse tracking issues (see https://bugzilla.gnome.org/show_bug.cgi?id=745032)."

Ubuntu 17.10 uses wayland by default. however, you can switch back to Xorg, without to install anything, all you need to do is:

  1. Log out from you current user.

  2. Under the password, near the "unlock" button, you will have something like a settings-icon.

  3. Click it, and choose the second option(the one says "xorg")

  4. And there you have it! the good old xorg session, with no more cursor lags!

"Switching to an Xorg session from the log in screen should solve it."

  • 2
    Looks like GDM3 is using Wayland by default too. I also needed to disable Wayland in GDM by uncommenting the WaylandEnable=false in /etc/gdm3/custom.conf – Colin Harrington Oct 24 '17 at 18:18
  • 4
    This solution doesn't work. It didn't work for me, and many others, as you see in the answers of: askubuntu.com/questions/966954/… (It appears to be a genuine problem with Gnome & an unresolved bug as of now) – Loves Probability Oct 27 '17 at 4:37
  • @LovesProbability This mouse lag issue is widely known and specifically relates to Wayland. The general lag is a separate issue and not being asked by this question. – Taiko Oct 28 '17 at 6:18
  • 2
    I'm using xorg and the nvidia driver and definitely seeing the same lag issule. It seems to be a gnome problem, not a wayland problem. – aneccodeal Nov 16 '17 at 1:03
  • Great job on this. My guess would be that Gnome these days basically requires that your video card have a GPU. Otherwise (as everyone has reported), the mouse and keyboard lag render Ubuntu completely unusable. Such was the case with my otherwise-screaming 32GB 8-way server--since it still has a 'dumb' raster buffer (CPU-access only) video card. – Glenn Slayden Dec 17 '17 at 8:19
-1

Just sharing my case.

My laptop : i7(kabylake) + HD620 graphics card. I read that usually its the driver's problem. so,

Installed Intel HD620 graphics driver, and mouse lagging was solved. Intel driver currently only support 17.04. So I followed below answer.

How to Install the latest Intel Graphics Driver in Ubuntu 17.10?

(edited following the advice)

Basically,

  • Backup and edit your /etc/lsb-release file to fool the installer.
  • Download and install Intel driver.
  • Change /etc/lsb-release back to original.

But, mouse lagging still happens when I use Transmission(torrent client) downloading about 5 files. other than that, looks good.

Another thing is by installing the graphics driver, it solved the problem of a blank tool tip when moused over anything first time, so I had to put mouse over repeatedly, but it's now solved too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.