2

I have done the switch from Ubuntu 17.04 to 17.10, but when I downloaded Steam, and opened one game, it crashed after one minute of playing.

I want to mention that it happend on Ubuntu 17.04 as well, but only in TF2.

I've tried many games, and I got the same result, the game freezes, then it has a sound loop, then it crash, but I do not get any error message. (most of them are working on OpenGL)

I have Intel Core i5-6198DU CPU @ 2.30GHz x 4, Intel HD Graphics 510(Skylake GT1), GNOME 3.26.1, 8GB ram, 64-bit.

And I don't have any graphics driver installed.

Can you please tell me what should I do to make it work again? (and please if you want me to post logs and stuff, explain where do I need to find them, because I don't know much about it.)

journalctl -n 1000 gives me this output https://pastebin.com/gSZNMwK4.

Important edit: The games don't work in unity, gnome,either on xorg, or wayland session, in fact, after the game crashes I get a messagebox saying report a bug, but nothing happens after I click report.

Thank you in advance! enter image description here

20
  • 1
    Is this under the Wayland based session, or Xorg? If Wayland, perhaps try logging out and switching to the Xorg session, to see if it helps.
    – dobey
    Oct 21, 2017 at 21:05
  • @dobey its not, no matter what session do I use, but thanks for your help:)
    – Argaman
    Oct 21, 2017 at 21:14
  • I have a similar problem and had to revert to 17.04. My computer would just self-shutdown with any Steam game requiring my CPU to go in turbo mode, after a while. For games requiring less CPU oomph, the performance would still be far worse than 17.04. This seems to hint that the video drivers / GPU might not be the issue, as I've replicated with a number of Nvidia drivers for my Geforce 1060, but you're on an Intel driver. Maybe try downgrading to 17.04...
    – Mena
    Oct 23, 2017 at 15:09
  • @Mena Thanks for the advice but I dont think so..
    – Argaman
    Oct 23, 2017 at 16:16
  • 1
    Is there anything interesting in the syslog? (/var/log/syslog)
    – Kobi T
    Oct 25, 2017 at 18:58

1 Answer 1

1

This sounds like there is a problem with a PCI Express device not properly communicating with the Root port. I suspect this may be a kernel issue. You could try using a different kernel, e.g. with: https://wiki.ubuntu.com/Kernel/KernelPPA

PS: This was meant as a reply to your comment... got the wrong field. Can you maybe update the original question, if this solution is was useful?

10
  • oh man I know how to fix the syslog issue , thats not my problem. but thank you anyway:) askubuntu.com/questions/771899/…
    – Argaman
    Oct 26, 2017 at 11:57
  • lets have a look at the log, when the game is crashing
    – noreabu
    Oct 26, 2017 at 13:01
  • I edited my question, but basically are you saying that the cause for the crash is the pci express?
    – Argaman
    Oct 26, 2017 at 13:26
  • @Argaman I looked your journalctl, and I see at least a thousand entries every second. I don't know if it's relevant to the crash, but I bet it impacts a performance. If you have means to fix it, I really advice to do so. Regarding the crash: there's no info about it in logs because of the hw-error spam. You can try then running the game from a terminal, and to paste game output in your question. It's just, running a steam game from a terminal require a bit of tackling, like searching its binaries, and maybe some args, as opposed to plain looking journalctl… But you can try it too.
    – Hi-Angel
    Oct 26, 2017 at 13:38
  • @Hi-Angel but I dont really know how to fix it, I mean I found a solution but I dont know how to do it properly, can you please help me fix the problem with the pci?
    – Argaman
    Oct 26, 2017 at 13:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .