2

I have 200 chars in width, and only 2 old eyes. That's too much of too little :)

I've seen various answers on these forums, but none of them seemed to help me.

:~$ sudo hwinfo --framebuffer | grep Mode
Model: "Intel(R)Sandybridge Mobile Graphics Controller"
SNIP! 
Mode 0x0318: 1024x768 (+4096), 24 bits
SNIP!

Is the resolution I'm going for

(I've cut away a lot of resolutions there)

I'm on Oneiric which of course means grub2

3 Answers 3

2

You can try setting a larger font:

setfont /usr/share/consolefonts/Uni3-Terminus32x16.psf.gz

This sets a nice, large, readable font. Check /usr/share/consolefonts for available fonts, each one has different point sizes.

Oh, and this works on a per-console basis so you can have a different font for each TTY.

1
  • ah - that's an even easier way of doing it, thanks!
    – Acebone
    Jan 18, 2012 at 23:17
1

It is now set by grub

Edit /etc/default/grub

# graphical
gksu gedit /etc/default/grub

# Command line
sudo -e /etc/default/grub

and look for the following lines

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

Uncomment the last line, and set your desired resolution.

GRUB_GFXMODE=800x600

Then update-grub

sudo update-grub

Reboot

See also https://help.ubuntu.com/community/ChangeTTYResolution

5
  • 1
    While your answer is indeed the 'canonical' answer ... it doesn't help me. The grub bootloader does change resolution, but not the <Ctrl><Alt>F1...F6 TTYs They are still too small ... no change in them ...
    – Acebone
    Jan 18, 2012 at 22:08
  • 1
    ok - i give up, i wanted to dutifully update my answer - but users who aren't 300 questions old are hassled in a manner that is just too much. HERES THE INFO The right question is: How do I get a bigger font size in the TTYs The answer to that question I found here: askubuntu.com/questions/86827/… sudo dpkg-reconfigure console-setup. From that program you can choose font and font-size I haven't booted yet, but you can check in the TTY by using the command setupcon To see if you hit something you can use
    – Acebone
    Jan 18, 2012 at 22:28
  • update my question I meant
    – Acebone
    Jan 18, 2012 at 22:29
  • @user42584 post that as an answer. You will soon have enough reputation to make adjustments, it is a hassle at first, but be patient.
    – Panther
    Jan 18, 2012 at 22:31
  • I cannot post an answer yet ...
    – Acebone
    Jan 19, 2012 at 5:47
1

Just prevent the kernel from setting the mode using the "nomodeset"-kernel Parameter:

edit /etc/default/grub and add:

GRUB_GFXMODE="640x480" 
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Once you have saved the changes, run:

sudo update-grub

reboot - and the screen resolution will stay 640x480 for all ttys (Tested on Ubunutu Server 14.04)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.