4

Xenial (16.04) has systemd-229. Unfortunately, that version seems to still have a bug that prevents KillUserProcesses from working properly. See this bug.

So, I want to upgrade to at least 230, or even newer.

Since systemd is such a core plumbing to Ubuntu, how do I do this safely?

(edit: fixed version number)

  • Safely: You upgrade to a newer version of Ubuntu. As a bonus, most of your other software gets a version-bump, too. – user535733 Oct 20 '17 at 1:34
  • @user535733 No, thanks. There's not yet any LTS version after 16.04. – pepoluan Oct 20 '17 at 1:52
4

You have five options. You will need to decide which criteria (LTS, safe, easy, fast) are more important - no option meets all of them:

  1. Wait for 18.04 LTS. This is safe, but it does not fix your problem.

  2. Install 17.04 or 17.10 (non-LTS). This is also safe, but you seem to not like this one.

  3. File a Stable Release Update request on Launchpad to get the fix backported to 16.04. This is reasonably safe - SRUs are well-tested. SRUs take time, and may be rejected entirely by the developers.

  4. Try installing a systemd package from a newer release of Ubuntu. This is almost certainly not safe at all, and risks breaking your system horribly.

  5. Learn to compile systemd, and install a newer version. This requires great skill and patience to do properly. Many, many opportunities for breakage and frustration, not safe at all unless you have years of experience with compiling and init.

  • I would NOT install 17.04 and expect to upgrade 17.10 -> 18.04 at this moment, too many changes to call "safe" by any stretch. I would consider a fresh install of 17.10 in a month anticipating an upgrade to 18.04 to be as safe as it gets with the fresh install and upgrade approach. – Panther Oct 20 '17 at 2:48
  • @bodhi.zazen agreed. Since the OP already rejected that option, I didn't spend a lot of time qualifying it, nor wandering down the slippery slope of comparative safety. That would be a whole book, eh? – user535733 Oct 20 '17 at 2:55
  • agreed, but just mentioning the issues as I am guessing the OP has not done much if any research into the changes 17.10 brings. – Panther Oct 20 '17 at 3:02
  • @Panther true. There's a reason why I insisted on LTS (in this case, 16.04), because it "should be good" until 2021. I don't have to keep myself constantly up-to-date with "latest and greatest". – pepoluan Nov 10 '17 at 2:32

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.