1

This question already has an answer here:

I have not much experience with ndiswrapper but some vague memory of using it with some broadcom module long back. Now, here is the problem. Realtek RTL8723DE wireless module is used in my new HP 15-BS576TX laptop. I haven't installed Linux yet. But, would like to check if Ndiswrapper can help use the Windows driver to work in Linux. Here is the Windows 10/8/7 driver for this RTL8723DE wlan module: ftp://ftp.hp.com/pub/softpaq/sp80501-81000/sp80963.html

I extracted the exe and can see a folder /RTWLANE_Driver/Wind7X86/ which has rtwlane.sys and few other files which I presume is related to the wireless driver. Is there any chances of luck with ndiswrapper considering the driver executable actually contains win8/win7 drivers.

Thank you.

marked as duplicate by Fabby, terdon Dec 27 '17 at 13:36

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • ndiswrapper requires Windows XP drivers; from man ndiswrapper: "ndiswrapper - Linux kernel module and user space tool to load and run Windows XP drivers for wireless cards." I have seen many attempts to use the Win7 inf and sys files, however, none were successful. – chili555 Oct 19 '17 at 20:57
  • Ah..then I should wait for the native driver from realtek. meantime, getting a cheap usb wireless card to work with Linux. – Confguy2016 Oct 20 '17 at 9:26
  • That's exactly what I'd suggest. – chili555 Oct 30 '17 at 19:49
3

To install the module for the RTL8723DE chipset, first determine your kernel using uname -r if your kernel is lower than 4.11, do

sudo apt-get install build-essential dkms git
git clone -b 4.10-down https://github.com/jeremyb31/rtl8723de.git
sudo dkms add ./rtl8723de
sudo dkms install rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414
Then reboot

If you have kernel 4.11 and newer do

sudo apt-get install build-essential dkms git
git clone https://github.com/jeremyb31/rtl8723de.git
sudo dkms add ./rtl8723de
sudo dkms install rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414
Then reboot

If you wish to stop power management for the device and change the logging level to minimum

echo "options 8723de rtw_power_mgnt=0 rtw_drv_log_level=0" | sudo tee /etc/modprobe.d/8723de.conf

If you have UEFI, Secure Boot will need to be disabled for the module to load.

  • Thanks! that is a better way to build and install the module. – Confguy2016 Dec 23 '17 at 3:47
  • But, this is not working. ERROR (dkms apport): binary package for rtl8723de: 5.1.1.8_21285.20171026_COEX20170111-1414 not found – Confguy2016 Dec 23 '17 at 4:07
  • Try doing a cd Downloads and then run the commands. I found an issue with the dkms.conf on the original github source and have changed this to my own github – Jeremy31 Dec 23 '17 at 11:43
  • The binary package not found usually means the sudo dkms add command failed. The dkms worked perfectly after I fixed the dkms.conf file – Jeremy31 Dec 23 '17 at 14:25
  • Actually, I was using smlinux git repository. I pulled and merged again and dkms built the module fine. BTW, did you notice so many messages in kern.log with this driver? – Confguy2016 Dec 24 '17 at 11:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.