I've installed GNOME-Shell from the software centre and it installed with no problems. However when I log out, select GNOME from the dropdown menu and log back in, it just loads Unity.

Any ideas? I'm running 11.10 on an older Toshiba Satellite A100.

I'm using Unity 3D right now. As for specs, it's a dual-core T5200 1.6GHz with the 945GM integrated graphics and 2GB RAM.

If I disable auto-login I can get it to load. I've tried a couple of the auto-login tricks that I've read about but they don't work. I've tried editing /etc/lightdm/lightdm.conf and it didn't work. I don't remember exactly what else I tried.

  • I am curious, why use Autologin and are you saying that disabling works but you arent sure why? – XXninjatooXX Feb 4 '12 at 21:20
  • Problem is solved. Scroll down. – ssyd Feb 9 '12 at 3:06

Gnome-Shell is pretty picky and at least for me, easy to break.

I would first check your Xorg log, for me it's: /var/log/Xorg.0.log.

Also check your .xsession-errors in your home directory.

Xorg should tell you what is happening. That is standard behavior for Gnome-Shell, its likely the fallback session.

You can also check system info under System Settings -> System Info. Check the Graphics line under Summary to confirm the correct graphics card. Check Experience line under Graphics.

That's where I would start. I'm always messing with things and breaking my window environment :D

Report back if you figure it out.


  • Xorg.0.log looks like everything is running fine but .xsession-errors is full of entries that just repeat. Most of what is in the error log is these lines: (nautilus:1390): GLib-GObject-CRITICAL **: g_value_get_object: assertion `G_VALUE_HOLDS_OBJECT (value)' failed ** (process:1578): WARNING **: recent-manager-provider.vala:125: Desktop file for Banshee was not found – ssyd Feb 1 '12 at 2:50
  • I just tried to load KDE Plasma and it doesn't load either. It's not just GNOME. – ssyd Feb 1 '12 at 20:33
  • Thank you for your help but I've figured this out. – ssyd Feb 1 '12 at 23:51

Problem solved:

  1. Disable auto-login in User Accounts
  2. Log out
  3. Select GNOME and log in
  4. Re-enable auto-login in User Accounts

It's strange that this doesn't work as intended for me but all it took was this small workaround to get GNOME loading on startup.


theres a guide on how to make unity look like classic in issue 56 of full circle magazine http://dl.fullcirclemagazine.org/issue56_en (its in .pdf format btw) using gnome­-session-­fallback

  • 2
    I don't want classic. If I wanted classic Linux I'd have downloaded Kubuntu. I want to try GNOME-Shell 3. – ssyd Jan 20 '12 at 23:47
  • Gnome shell kicks ass. There are a bunch of updates that came out recently that fix many GS issues. I suggest making sure its updated and try enabling auto login again... just to see :p – XXninjatooXX Feb 4 '12 at 21:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.