9

In Ubuntu 17.10 right tray icons (e.g. Telegram,Skype etc.) are very small, and gnome-shell-extension-top-icons-plus does not work in 17.10.

How can I fix it?

3

You can't remove gnome-shell-extension-appindicator, ubuntu-desktop depends on it. Solution that works for me (but You do it on your own risks):

sudo apt-get remove gnome-shell-extension-appindicator
apt-get download ubuntu-desktop
sudo dpkg --install --ignore-depends=gnome-shell-extension-appindicator ubuntu-desktop_1.404_amd64.deb

For ignoring broken packages in Ubuntu (from this source), run:

sudo gedit /var/lib/dpkg/status

This should open the file status (which can be pretty long), you now have to find the package name ubuntu-desktop. Now delete the dependencies gnome-shell-extension-appindicator from the Depends line, save the file (Ctrl+S) and close.

Now install TopIcons Plus and KStatusNotifierItem/AppIndicator Support.

|improve this answer|||||
  • 2
    Nice! Now it looks like a proper answer. But one thing I want to mention, you should never start a graphical application like gedit with normal sudo. As an alternative you may use nano to edit text in the command line or run sudo -H gedit. – pomsky Oct 21 '17 at 12:32
  • If one also edits /var/lib/dpkg/status first, then there is no need to install ubuntu-desktop after the removal of appindicator. But awesome answer though. – chesedo Jan 10 '18 at 13:24
2

I have the same problem after upgrading from Ubuntu Gnome 17.04. I tried a lot of fixes, but none of them helped me. I decided to reinstall Ubuntu. After a fresh install, the issue still persists, but there is a kind of workaround that is working for me. As described here: In terminal execute export XDG_CURRENT_DESKTOP=Unity then run the app ./Telegram & exit. The result is a litte bit bigger icon in the tray and a badge indicator on the icon in the dock. enter image description here

|improve this answer|||||
  • it's work surprisingly! – Sajad Bahmani Oct 28 '17 at 11:10
  • 1
    i change in .local/share/applications/telegramdesktop.desktop Exec=env XDG_CURRENT_DESKTOP=Unity /home/$user/apps/Telegram/Telegram -- %u – Sajad Bahmani Oct 28 '17 at 11:20
2

You have to edit /usr/share/applications/telegramdesktop.desktop which is telegram launcher. Change line

Exec=telegram-desktop -- %u

to

Exec=env XDG_CURRENT_DESKTOP=Unity telegram-desktop -- %u

You can do the same workaround for Slack too.

|improve this answer|||||
2

You may first install TopIcons Plus from extensions.gnome.org or its GitHub page.

But the default Ubuntu appindicators will not let TopIcons Plus work properly. So you will have to deactivate/remove it first.

You may deactivate Ubuntu appindicators from the Extensions section of (GNOME) Tweaks (suggested by Charles Green). To install Tweaks run

sudo apt install gnome-tweak-tool

Alternatively if you are absolutely sure that you want to remove Ubuntu appindicators, then run (not at all recommended, it will remove ubuntu-desktop metapackage)

sudo apt-get remove gnome-shell-extension-appindicator 

or remove the ubuntu-appindicators@ubuntu.com directory from /usr/share/gnome-shell/extensions.


Now TopIcons Plus should work as expected. You may change its settings using the indispensable GNOME Tweak Tool (aka Tweaks). If it is not installed, you can install it by

sudo apt install gnome-tweak-tool

Then launch GNOME Tweak Tool and change the settings of TopIcons Plus (for example icon size, spacing etc.) from the Extensions section.

|improve this answer|||||
  • 1
    not work in ubuntu 17.10 – Sajad Bahmani Oct 19 '17 at 15:44
  • what is appindicator? – Sajad Bahmani Oct 19 '17 at 19:46
  • @SjB Ubuntu appindicators is an extension shipped by default which shows icons of apps like Skype, Telegram etc. on top right (in a way an alternative to TopIcons Plus). But clearly it's not working correctly, showing tiny icons. It seems disabling it using Tweks is not enough. So I'm suggesting you to remove it and use TopIcons Plus. Try my answer. – pomsky Oct 19 '17 at 19:49
  • @pomsky Rather than remove gnome-shell-extension-appindicator, it can be turned off in the GNOME tweak tool (Ubuntu appindicators) – Charles Green Oct 26 '17 at 14:22
  • @CharlesGreen I see. Thanks for the suggestion. I have added that to the answer. I suggested removing Ubuntu appindicators completely as OP confirmed more than once that disabling it didn't do anything for them, but now I think they didn't. Later OP said "What is appindicator?"! – pomsky Oct 26 '17 at 14:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.