0

I have 2 PCs with Linux Mint 17.X and Ubuntu 16.04 respectively. Now I want to share a folder between these 2 PCs. I've followed the following steps :

  1. Right click on the folder I want to share.
  2. Select "Sharing options".
  3. Select "Share this folder" and "Allow others to create and delete files in this folder".
  4. And click "Create share".

After this the folder icon has also been changed. But unfortunately I still can't access it on the other computer.

How to solve this issue? Please help.

Sharing window

Changed folder icon

  • Can you access it from your sharing host? e.g. by smb://localhost/TestF ? – Ziazis Oct 19 '17 at 10:35
  • Maybe the tips by Morbius at the following link may help get samba working, ubuntuforums.org/… – sudodus Oct 19 '17 at 12:02
1

A good way to share a folder between two linux computers is to make one of them an SSH server. You can make the Ubuntu computer an SSH server by installing openssh-server.

sudo apt install openssh-server

Then you can connect remotely from the other computer via the simple command line tool ssh to log in an run remotely or sftp to transfer files.

ssh user@IP-adress

or to be able to run GUI application programs remotely

ssh - X user@IP-adress

or transfer files

sftp user@IP-adress

for example

ssh sudodus@192.168.0.2

You can use GUI tools, for example the file browser Nautilus or the dedicated tool Filezilla with the text

ssh://user@IP-adress

for example

ssh://sudodus@192.168.0.2

in the box for location of the directory you want to see. You can save it as a bookmark, and manage the remote directory seamlessly.

enter image description here

enter image description here

If you have a Windows computer, you can install Filezilla for Windows or WinSCP and connect to the remote directory in the same way.

If you are working locally in your own local network behind a firewall you can do it with password authentication, but using keys increases the security if the system is accessed via the internet or if other people have access to the local network. It is also more convenient to use keys because you need not type the password to get access.

https://help.ubuntu.com/community/SSH

https://help.ubuntu.com/lts/serverguide/openssh-server.html

0

You probably haven't set up a network between the two computers.

Or you can use:

Personal File Sharing

The Personal File Sharing tool – also known as gnome-user-share – was the original reason for the Public folder. It uses Apache to offer convenient WebDAV-based file sharing, but doesn’t work with Windows systems. It supports Bluetooth file sharing, too. To use it, you’ll have to install the appropriate packages:

sudo apt-get install gnome-user-share apache2.2-bin libapache2-mod-dnssd

After you do, you’ll find the Personal File Sharing application in your Dash.

With the Personal File Sharing application, you can enable easy sharing of your Public folder over the network – it only works with the Public folder, not other folders. You can require a password never, when writing files, or whenever the share is accessed. You an also enable easy sharing and receiving of files in the Public folder over Bluetooth.

Open the Network pane in the Nautilus file browser and you’ll see each Public folder shared on the network

Source: https://www.howtogeek.com/116309/use-ubuntus-public-folder-to-easily-share-files-between-computers/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.