1

Because I install PHP5.6.31 from source so I can't use this command:

apt-get install php-ssh2 

to install SSH2 module for PHP.

Now I try to install this module from source. I read this install step

1. download the libssh2 package from http://libssh2.org, command as following:
   tar vxzf libssh2-1.4.2.tar.gz
   cd libssh2-1.4.2
   ./configure
   make
   make install

2. download the php-ssh2 package from http://pecl.php.net/package/ssh2:

tar vxzf ssh2-0.11.3
cd ssh2-0.11.3
phpize
./configure --with-ssh2
make
make install

and the ssh2.so file will copy into /usr/lib64/php/modules
check it.
  1. modify the php.ini

vi /etc/php.ini add the "extension=ssh2.so" to the extension part of php.ini

  1. check the environment of php, use phpinfo();

But I fail in step 2: enter image description here

Please help me. Thank in advance.

  • 2
    Please avoid upload terminal screenshot, instead copy the output to the post. – Emmet Oct 19 '17 at 2:59
3

You're missing the package which essential in order to run the script properly, simply install.

sudo apt-get install autoconf
  • yes, it's work, thank you, but can you help me this step copy to "/usr/lib64/php/modules" and step 3 "modify the php.ini", because I install from source so I can found these file. – nistelrooy41001662 Oct 19 '17 at 3:28
  • I think the "and the ssh2.so file will copy into /usr/lib64/php/modules" part is automatic as you ran make and make install. The manual tell you to check whether the actual file is already copied to /usr/lib64/php/modules. – Emmet Oct 19 '17 at 3:39
  • And the php.ini file is a configuration setting for php, you need to modify them in order to load the extension. Read askubuntu.com/questions/356968/find-the-correct-php-ini-file. – Emmet Oct 19 '17 at 3:44

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.