29

I have a brand new Dell i7 Skylake laptop, brand new Samsung Pro 960 SSD, New Windows 10 build 16299 (Fall Creators Update released yesterday) just upgraded from build 15063.

I downloaded Ubuntu from Windows Store but got this error:

The WSL optional component is not enabled. Please enable it and try again.
See https://aka.ms/wslinstall for details.
Error: 0x8007007e
Press any key to continue...

I googled the recommended site and passed the hex error code with no luck.

Rebooting didn't help.

Any ideas?

45

Your Windows Subsystem for Linux (WSL) is not turned on. To turn on open PowerShell as Administrator and run the following command:

Enable-WindowsOptionalFeature -Online -FeatureName Microsoft-Windows-Subsystem-Linux

Source: https://docs.microsoft.com/en-us/windows/wsl/install-win10

| improve this answer | |
  • work to me after 'reset' Ubuntu WSL – rmsys Jun 17 at 21:26
6

I guess we are spoiled in the Linux world with sudo apt install that goes out to find dependencies and install them for us. As it turns out Ubuntu for Windows requires you to go into "Windows Features" and turn on "Windows Subsystem for Linux" as detailed in this bug report.

After rebooting and launching Ubuntu again; I got the following messages:

"Installing, this may take a few minutes..." [healthy coffee break; YMMV]
Installation successful!
Please create a default UNIX user...

and completed the second phase to install/initialize Ubuntu in WSL (Windows Subsystem for Linux).

| improve this answer | |
  • 1
    ye this answer is IMPORTANT! – silentsudo Aug 9 '19 at 18:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.