After installing Ubuntu 11.10 on a new computer everything worked fine for a few weeks and now suddenly when starting up Ubuntu I get a blank purple screen with no "Ubuntu" splash and the 5 dots but the system does start up.

What has happened to loose the Ubuntu splash screen?

Also, I've checked in the Grub startup and it has quiet splash in the Linux line.

I have an ATI Radeon 5450 graphics card which needed nomodeset to be added to the Grub line when booting for the first time off the install CD but now this line has disappeared from the grub startup.

Can anyone help?

  • Open the Ubuntu Software Centre and search for Plymouth and tell us if you still have the Graphical Boot Animation & Logger installed and also the Add-on ubuntu-log-theme. It would also help if you told us about any modifications you might have done in the few weeks since installing. – grahammechanical Jan 18 '12 at 21:11
  • 1
    Hi, Yes I have Plymouth and Graphical Boot Animation & Logger installed. Searching in Synaptic I have found the ubuntu-log-theme is install too. I haven't made any modification or alterations to the grub setup since installing the clean system. – Peter Jan 18 '12 at 22:11
  • Something has changed AGAIN! I have not touched any system settings and now on bootup I get the purple blank screen as described above, and then just a split second before ubuntu desktop loads I see the normal "Ubuntu" with 5 redish dots beneath it. Now how on earth is my system changing itself!!! – Peter Jan 20 '12 at 8:39
  • This is what fixed it for me: askubuntu.com/a/6074/18665 – bmaupin Dec 25 '13 at 20:05

After searching and searching online I've found the answer to this problem and the solution is quite simple.

Apparently it's because the graphic drivers don't load quickly enough during the booting sequence so by the time the graphic drivers are ready booting has almost finished and thus either no plymouth screen is shown or a very quick fast of it is seen.

So the solution I found and it works is to add a simple line to the following file.

gksu gedit /etc/initramfs-tools/conf.d/splash

then add:


Save the file, and then :

sudo update-initramfs -u -k all

This command will update the initial ramdisk containing the drivers needed by the kernel at boot time. The parameter -k all updates all of them if you have more than one kernel installed. Reboot and all is well.

This works in ubuntu 12.04 too.

Hope this helps anyone who is missing the lovely Ubuntu boot screen.

| improve this answer | |
  • 2
    Slows down the booting process of Ubuntu. You'd be better off without this if you want fast booting. – abybaddi009 May 11 '12 at 11:26
  • Experiencing this too with the proprietary nvidia driver, configured for high resolution VTTY. Will try if disabling the framebuffer saves some time at boot. At shutdown plymouth works fine, because the driver is correctly loaded. – LiveWireBT May 11 '12 at 11:52
  • After applying the changes I've noticed no slow down in boot speed. I have an intel i7 processor which might help but I can honestly say that it boots just as fast as before but I get the ubuntu plymouth splash screen. – Peter May 11 '12 at 20:30
  • I didnt know so far that ubuntu has a "boot-up" animation :P – kernel_panic Oct 6 '12 at 18:26
  • doesn't work in 13.04 with NVIDIA Proprietary drivers installed – SimplySimon Jun 6 '13 at 14:28

i solved the problem:

  1. Open /boot/grub/grub.cfg (use sudo gedit in Terminal to load it)
  2. Remove all $vt_handoff (Note: before this action, please make a backup from grub.cfg)
  3. Save it.
| improve this answer | |
  • Not for me on 13.04 :( – SimplySimon Jun 6 '13 at 14:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.