I have set my keyboard to Dvorak system wide, but it isn't used for the login screen forcing me to use an on-screen keyboard.

I do have the keyboard settings menu where it should be, but it doesn't seem to do anything.

I had just solved a similiar issue with my screen settings being the wrong way by copying my user settings into the light.dm folder (sudo cp ~/.config/monitors.xml /var/lib/lightdm/.config/), can I do something similiar, but with the keyboard settings instead?


  • Which Dvorak layout, more precisely? One way to let us know is to show us the output from the command gsettings get org.gnome.desktop.input-sources sources – Gunnar Hjalmarsson Oct 18 '17 at 19:18
  • Cool, thanks. [('xkb', 'us+dvorak'), ('xkb', 'ca+eng')] I forgot to add it into my post (as it is likely unrelated), but Unity-Control-Center is not working, so I have no access to the GUI for system settings and a few other things. What does "xkb" mean? – J.Tho Oct 18 '17 at 19:25
  • xkb is the keyboard configuration system used on most Linux distros. I posted an answer, which might be what you need. – Gunnar Hjalmarsson Oct 18 '17 at 19:40
  • Btw, if you use Unity, and unity-control-center isn't working, your system is severely broken. You may want to ask another question, if you want help to fix that. – Gunnar Hjalmarsson Oct 18 '17 at 19:43

I suggest that you open /etc/default/keyboard for editing and change the line starting with XKBLAYOUT to:


(I assume that there is currently something else.)

After next reboot, the Dvorak layout will hopefully be effective on the login screen.

  • I edited the file to what you specified and rebooted, but it is still stuck in qwerty. Also; unity is working now, I don't know why. – J.Tho Oct 19 '17 at 0:05
  • @J.Tho: I see. Then I'm out of ideas, unfortunately. Maybe someone else can help. – Gunnar Hjalmarsson Oct 19 '17 at 8:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.