Firstly, here are some command outputs related to my wireless adapter(running in a Lenovo IdeaPad Y700-15ISK laptop):

$ sudo lshw -class network
       description: Wireless interface
       product: Wireless 8260
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:08:00.0
       logical name: wlp8s0
       version: 3a
       serial: a4:34:d9:51:f8:6a
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=4.10.0-37-generic firmware=21.302800.0 latency=0 link=no multicast=yes wireless=IEEE 802.11
       resources: irq:131 memory:94100000-94101fff

$ lspci -nnk | grep 0280 -A2
08:00.0 Network controller [0280]: Intel Corporation Wireless 8260 [8086:24f3] (rev 3a)
    Subsystem: Intel Corporation Wireless 8260 [8086:1010]

I've already noticed that there were posts about issues with this wireless adapter in older Ubuntu versions (14.04), but those fixes mentioned there didn't apply for my issues.

What are the issues, you ask? Firstly, the network is unstable. It often tends to have some speed leaks when ping just climbs up and it's basically unusable. This appears to even make kinda pulse-like pattern where it slows down for like 2-3 minutes, then again works ok for like 10 minutes. Haven't done any real testing, though. Secondly, the nm-applet tends to bug out. What this means is that over time the icon can get unresponsive, loose animations. Also, networks can just randomly drop out of the dropdown list.

The procedure of running sudo service network-manager restart and killall nm-applet && nm-applet & works as kinda temporary fix, but by temporary I mean around 10-15 minutes.

As you can probably tell, the situation is pretty bad. It didn't use to be like this before. Even in Ubuntu 16.04.2 around a month or two ago it was working all fine. I am not really sure what happened, but it's really bothering me.

edit Last few days it starts to feel as if it's getting worse. Instead of how it was previously when it was usable most of time, but periodically worsened, now it's nearly unusable all the time, with just a few "splashes of internet" when something tends to work at all. This problem can't even be reduced or anything. I'm running my laptop in like a 90% offline mode. This problem is the most annoying thing I've ever experienced. I really need the solution to this, and need it quick before my CNS turns into a hot liquid.

  • Have you tried connection with ethernet? OR with Live OS (from CD or USB stick)? I have a strong feeling this is hardware related problem (Live CD could prove this feeling). – V-Mark Oct 30 '17 at 22:35
  • I haven't tried with ethernet or live OS. Will try it soon. If it's hardware problem, do you suggest me contacting warranty? – Adrians Netlis Oct 31 '17 at 15:50
  • i think i have the same problem... askubuntu.com/questions/1052618/… – gep Jul 6 '18 at 12:50

There is a reported (in comment) solution in this question which indicates that setting a few options in iwlwifi seem to fix several issues.


sudo modprobe -r iwlwifi && sudo modprobe iwlwifi bt_coex_active=0 11n_disable=8

If this works, you can add the options to the config file with

sudo -i
echo "options iwlwifi bt_coex_active=0 11n_disable=8"  >>  /etc/modprobe.d/iwlwifi.conf

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.