2

It's that time I boot a new OS on my system but I keep getting a "not a COM32R image" I wrote it on a half a dozen flash drives using two different computers using the l three different computers, and it doesn't work. I've been using Ubuntu 14.04.v what is going on? Both are 64bit systems and worked before, why not now?

  • It seems a bit out dated. It was hard to understand. – Mr. Randall Oct 18 '17 at 7:49
4

General

This is a known bug in some versions of tools to create a USB boot drive. The problem is, that they use program parts from an old version of syslinux together with a new version of syslinux from the iso file. Updated versions of these tools can manage this problem. Cloning tools are not affected, because they put only data from the iso file into the USB pendrive.

Fortunately there are other tools. All current versions of Ubuntu come as hybrid iso files, and such files can be used to burn DVD disks and USB boot drives by cloning (copying every byte exactly as it is from the iso file to the target device).

There are also extracting tools, that are not affected by this bug.

Cloning tools

  • In Ubuntu and many other linux distros you can use

    • mkusb version 12 with mkusb-dus

      If you run standard Ubuntu, you need an extra instruction to get the repository Universe. (Kubuntu, Lubuntu ... Xubuntu have the repository Universe activated automatically.)

      sudo add-apt-repository universe  # only for standard Ubuntu
      
      sudo add-apt-repository ppa:mkusb/ppa  # and press Enter
      sudo apt-get update
      sudo apt-get install mkusb mkusb-nox usb-pack-efi
      

      enter image description here

      enter image description here

    • Disks alias gnome-disks which is often already installed, but a little more difficult to use:

      1. select drive

      2. select 'Restore' at the main menu

      3. select image to restore, in this case iso file

      enter image description here

  • In Windows you can use Win32 Disk Imager

Extracting tools

  • In MacOS you can use Unetbootin. Old versions may be affected by this bug, but if you get a new version, it should work well not only in MacOS, but also in Windows and Linux.

  • In Windows you can use Rufus. The main operating mode is extracting, but you can select dd mode to make it clone.

  • I've tried Unetbootin and never has problems with older versions its of Ubuntu/Debian – Mr. Randall Oct 18 '17 at 7:48
  • Did you solve the current problem with Unetbootin? In that case fine :-) Otherwise, if you still need help, please tell me if it is the same problem as described in your original question or another problem now, and which tool(s) you have tried. – sudodus Oct 18 '17 at 8:40
  • This "not a COM32R image" bug is caused by different versions of syslinux, the bootloader for BIOS mode, {in the operating system, where you create the USB boot drive or the tool}, and the operating system in the iso file (that you want in the USB boot drive). The problem in some versions of some extracting tools is that they use program parts from the old version of syslinux together with the new new version from the iso file. Updated versions of these tools can manage this problem. Cloning tools are not affected, because they put only data from the iso file into the USB pendrive. – sudodus Oct 18 '17 at 8:52
  • To your first question "No I have up on it after I began talking write messages after an hour of and was told by others that it's a common problem because it's never updated." To your other statement "I've tried installing it on a windows system and it doesn't and got the same thing was able to get it to work once by using TAB ave doing "live" after that it stopped working, I figured that I could reformat the thumb drive but this time not make it persistent." – Mr. Randall Oct 18 '17 at 9:47
  • I want to make sure that I can run Live CD on money machines without incident. I have a version of Puppy Linux running on a Flash drive without my computer saying that there's a problem. I want to have my drive the booting LinuxMINT from my flash drive I got it to work once but it seems to have been corrupted because I have it persistent. If you can help with cloning I haven't been good with running mkusb, trying to install it didn't go well. Couldn't get the PPA working. – Mr. Randall Oct 18 '17 at 10:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.