33

How do I remove the "Trash" icon from GNOME 3 desktop? I'm running Ubuntu 17.10 with GNOME shell.

6 Answers 6

46

Up to Ubuntu 18.10

You may use (GNOME) Tweaks (aka GNOME Tweak Tool) to do that. First install it (if it is not installed) by running the following command in Terminal

sudo apt install gnome-tweaks

or

sudo apt install gnome-tweak-tool

Launch Tweaks and go to Desktop section. Then toggle off (or uncheck) the Trash (or Rubbish bin or Wastebasket) option under "Icons on Desktop".

enter image description here

Alternatively you may run the following command in Terminal:

gsettings set org.gnome.nautilus.desktop trash-icon-visible false
8
  • 1
    Just tested it in a VM. Works as advertised. Tested the GUI solution with tweak tools and the command line solution.
    – Videonauth
    Commented Oct 17, 2017 at 22:20
  • 1
    Can also confirm the terminal command works as advertised Commented Apr 28, 2018 at 7:18
  • For the CLI-oriented, the command is gnome-tweaks. Commented Sep 15, 2019 at 19:04
  • @tomislav They're the same thing.
    – pomsky
    Commented Sep 16, 2019 at 5:22
  • 1
    @scott Yes, because the way desktop icons are handled is changed fundamentally (handler changed from Nautilus to a shell extension), and this is the case since Ubuntu 19.04.
    – pomsky
    Commented Oct 30, 2019 at 13:35
14

After following Exien's answer on Ubuntu 20.04, the GUI became extremely slow and unresponsive. I had to reinstall Ubuntu even after reverting the value to true which did not fix the problem it generates.

In Ubuntu 20.04

It is actually easy:

  1. Search for Extensions (preinstalled) in the Activities overview.

    Search for Extensions (comes installed ready)

  2. Click on the Settings gear icon next to the Desktop Icons toggle

    Click on the settings gear icon next to the Desktop Icons toggle

  3. Toggle icons as required

    Toggle icons as required

1
  • 1
    It's probably just a red herring; your issues may have appeared coincidentally after running the command, but most likely only the command itself is not the cause. Running the command does (under the hood) exactly what toggling off in the Extensions app does.
    – pomsky
    Commented Jun 8, 2020 at 10:22
6

Ubuntu 19.04 and later

The following terminal command works:

gsettings set org.gnome.shell.extensions.desktop-icons show-trash false
2
  • Thank you for this. It's annoying that the developers didn't just provide this option in the properties menu of the icon or in a more accessible place in settings
    – Nav
    Commented May 2, 2021 at 15:23
  • Does not work in ubuntu 22.04 for me, I get No such schema “org.gnome.shell.extensions.desktop-icons” Commented Jan 22, 2023 at 21:51
1

The extensions don't work for ubuntu 21.04 just right click on the desktop and select "settings" you will find your options there

0
0

If the Extensions app doesn't show up in the Activities menu (as it did for me) you can use:

gnome-extensions prefs desktop-icons@csoriano

to open the window shown in Brendan's answer.

You can also hide all icons (including files) with:

gnome-extensions disable desktop-icons@csoriano
0

In Ubuntu 20.04, click the right upper corner of teh screen > Settings > Appearance (left side menu) > Configure dock behavior > Set off the "Show Trash" option

1
  • How is this different from the exact same answer already given?
    – David
    Commented Jun 5 at 6:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .