8

In Kubuntu 11.10, Okular does not seem to obey the CUPS default printer settings. So everytime I want to print something double-sided I have to select the option in Okular, really inconvenient. Is this a known bug? Any workarounds?

4

This seems to be a KDE/Qt bug:

Shortly ( http://bugs.kde.org/180051 ):

Description From Nicos Gollan 2009-01-08 19:02:22

There needs to be some way to have persistent printer settings. From looking around on the web, it seems like:

  • KDE 4 wants to use whatever Qt provides
  • Qt does not seem to provide any useful printer settings tools

There are patches but you need to compile the Qt-libs to use them. Or use non-KDE programs ( Comment #17 From C W J Lemmens 2009-11-20 11:44:47 ):

For our non-KDE programs (firefox, openoffice and some older stuff) I found a perfect replacement for "kprinter" : gtklp !! Take a look here : it solved more than half of my problems : http://gtklp.sourceforge.net/

1
  • For others: At the bottom of this link: bugs.kde.org/180051 there is a PPA with a patch for QT that fixes this. It worked for me. – evencoil Jan 18 '12 at 23:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.