7

I decided to upgrade to 17.10 on my Thinkpad.

Now every time I try to shut it down via console or menu) or reboot it, it takes ages.

TTY gives me several errors connected to hung_task_timeout_secs, reaching from kworker, over networkmanager down to wpa_supplicant.

I tried reinstalling with different ISOs (daily-build from 2 days ago, beta2, and the rc one from today) and still get the same error every time.

Any ideas what could cause that issue? Right now I'm running 17.10 on two other, different PCs without any problems whatsoever.

EDIT: deborphan doesn't return any orphaned packages. I think I might have found something though. I decided to completely wipe the disc, including my dualboot windows. Reinstalled, and everything worked fine. Today in university the problem reappeared.

Now the interesting part is: I think it is related to my wifi. At home, during installation and after, I had it plugged in via cable, and had no problems at all. But with only wifi in university it reappeared. So I gave it a try and plugged in the cable again at home, and it works again. Removed cable, restarted, and the problem reappears. Wifi-Card is a Qualcomm Atheros.

3
  • I've solved this error before and I discovered that it was caused by orphaned packages left over from the previous version of Ubuntu after completing the distribution upgrade. I identified the orphaned packages using a program called deborphan from the default Ubuntu repositories. Then I deleted all of them and ran sudo apt update and got a long list of error messages. Then I reinstalled the packages in the error messages and got more error messages. After an hour of recursing through the error messages the problem was solved.
    – karel
    Commented Oct 18, 2017 at 7:10
  • Because this is an advanced method please start by installing deborphan and editing your question with the results of the command deborphan. The command deborphan changes nothing in the filesystem, it simply lists orphaned packages. Please note that even if you can't uninstall all the orphaned packages it may still solve the problem if you only uninstall the orphaned package that was causing the problem.
    – karel
    Commented Oct 18, 2017 at 7:18
  • I had the same problem with the same wireless card. @legolas 's answer below worked for me (as a workaround). I'm using an earlier version of the kernel, and it is working now.
    – Menachem
    Commented Nov 9, 2017 at 15:12

3 Answers 3

5

Seems like a kernel issue related to wireless drivers and supplicant. I upgraded to 17.10 yesterday, and had the exact same problem. Removing orphan packages did not help.

After looking at dmesg output I realized it had something to do with the kernel (4.13.0-16-generic) and decided to use an earlier stable version (4.10.0-37-generic). Now everything works fine. Hope this helps.

Note: Below is the dmesg output:

wpa_supplicant[1488]: wlp1s0: CTRL-EVENT-SCAN-FAILED ret=-16 retry=1
 kernel: [  363.484267] INFO: task kworker/u8:1:51 blocked for more than 120 seconds.
 kernel: [  363.484281]       Tainted: G           OE   4.13.0-16-generic #19-Ubuntu
 kernel: [  363.484285] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
 kernel: [  363.484290] kworker/u8:1    D    0    51      2 0x00000000
 kernel: [  363.484359] Workqueue: phy0 ieee80211_ba_session_work [mac80211]
 kernel: [  363.484363] Call Trace:
 kernel: [  363.484380]  __schedule+0x28b/0x890
 kernel: [  363.484388]  schedule+0x36/0x80
 kernel: [  363.484396]  schedule_preempt_disabled+0xe/0x10
 kernel: [  363.484404]  __mutex_lock.isra.2+0x190/0x4e0
 kernel: [  363.484414]  __mutex_lock_slowpath+0x13/0x20
 kernel: [  363.484421]  ? __mutex_lock_slowpath+0x13/0x20
 kernel: [  363.484428]  mutex_lock+0x2f/0x40
 kernel: [  363.484472]  __ieee80211_start_rx_ba_session+0x1b7/0x5a0 [mac80211]
 kernel: [  363.484479]  ? dequeue_entity+0xed/0x4b0
 kernel: [  363.484516]  ieee80211_ba_session_work+0x164/0x250 [mac80211]
 kernel: [  363.484526]  process_one_work+0x1e7/0x410
 kernel: [  363.484532]  worker_thread+0x4a/0x410
 kernel: [  363.484537]  kthread+0x125/0x140
 kernel: [  363.484543]  ? process_one_work+0x410/0x410
 kernel: [  363.484548]  ? kthread_create_on_node+0x70/0x70
 kernel: [  363.484554]  ret_from_fork+0x25/0x30
5
  • What kernel version did you end up using?
    – Dappel
    Commented Oct 22, 2017 at 16:46
  • I am currently using 4.10.0-37-generic and was facing problems on 4.13.0-16-generic
    – Legolas
    Commented Oct 22, 2017 at 16:49
  • 1
    I had the same exact issue, and the same solution solved my problem. I am using 4.10.0-38-generic now.
    – Menachem
    Commented Nov 9, 2017 at 15:11
  • 1
    I had this same problem on Ubuntu 16.04 with kernel 4.4.0-169-generic (and 168). Had to bring back my Grub menu and boot with 4.4.0-166 to get the problem to stop happening. I suspect a recent update brought this problem back. Hoping future updates fix it again.
    – Sherri
    Commented Nov 28, 2019 at 14:27
  • Had the same issue with kernel 5.4.0-56 this morning while using a netgear wifi adapter.
    – Sary
    Commented Dec 4, 2020 at 18:06
4

It may well be this bug on Launchpad. A fix is promised in the "next Artful kernel release".

0

Okay, here follows now an alternative solution for that problem but with focus on Kubuntu 20.04 LTS. (Note, this was originally posted at the Archlinux forums.) It looks that there exist many different reasons which results then in the same error message.

I experienced this issue at a quite old Apple iMac5,1 computer. It looks that in my case there exist somewhere a problem with the GLX interface and especially in conjunction with older Radeon GPU models. This results then in a high "system load" which then blocks the entire KDE environment (X Window System) for 2 Minutes. Usually this happens right after the login when the "notification message" regarding the WiFi status is displayed.

The solution was for me to switch the whole KWin compositing from OpenGL / GLX to OpenGL ES / EGL. For this, the corresponding config file must be edited.

I added the following line:

export KWIN_COMPOSE=O2ES

To the following file:

sudo nano /etc/profile.d/kwin.sh

The result is really amazing! Almost everything is working better! There are in almost all parts of the UI behavior noticeable performance improvements. Interestingly, also Firefox, which uses also in my case the software based Webrender, runs smoother, great! :-)

For me it is incomprehensible why the OpenGL ES / EGL compositing option isn't available as default. At least for me it runs so much better than the standard OpenGL / GLX variant. Somebody should tell this the KDE or Kubuntu devs! ;-)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .