I have the same problem as is described here but that question doesn't have an answer and its OP doesn't seem like they will ever answer the arisen questions.

I installed google-earth-pro-stable_current_amd64.deb via sudo apt install on Ubuntu 16.04 64 bit.

Deleting ~/.xinputrc didn't change anything. When I log into a different account (account on my machine, that is – I don't think the commenter meant a different Google account (I didn't log into any Google account)), I experience the exact same problem.

It's not like a glitch which occurs for a few seconds and then vanishes. Google Earth just isn't usable because the map never shows up. It always shows the controls, part of the splash screen, and whatever was in the background when the application was launched.

What shows up when I launch Google Earth:

ttf-mscorefonts-installer already was installed.

Using gdebi didn't resolve the problem either.

Neither did using the 32 bit version.

  • Having installed the .deb from Google, I've also tried the Safe mode graphics, to no avail. – carnendil Oct 18 '17 at 0:27
  • Also, this seems to be a duplicate of askubuntu.com/q/956464/58950 which, although it might appear as abandoned, it's only one month old. – carnendil Oct 18 '17 at 0:38
  • @carnendil I linked to that question in the very first paragraph. I did, however, not see that it's "only" abandoned for a month but a year. Somehow, I read the date as "September 2016", not "September the 16th". – UTF-8 Oct 18 '17 at 10:15
  • I also thought it was "September 2016" the first time :). That's why I made the "duplicate" comment only later. I haven't found a solution to question yet. – carnendil Oct 20 '17 at 15:13
  • @UTF-8 , I am experiencing the same problem, even installing the 32-bit version didn't work. I was going to ask this as a separate question but found this question to be having exactly what I wanted to ask. If you've already found the solution by now please answer your own question, if not I am hopeful people viewing this will be able to find a solution to it soon. – Kewal Shah Oct 30 '17 at 19:56

I have found the solution to the problem:

Find the currently installed Google Earth package

dpkg --list 'google-earth*'

Uninstall the existing package:

sudo dpkg -P google-earth-stable

Install the googleearth-package package:

sudo apt-get install googleearth-package

Use the script to download the latest binary and create a .deb package:

make-googleearth-package --force

An example of the message you should get after executing the above command:

Description: Google Earth, a 3D map/planet viewer
 Package built with googleearth-package.
dpkg-deb: building package 'googleearth' in './googleearth_6.0.3.2197+1.2.0-1_amd64.deb'.
You can now install the package with e.g:

sudo dpkg -i googleearth_6.0.3.2197+1.2.0-1_amd64.deb

Install the .deb package as mentioned in the description:

sudo dpkg -i googleearth_6.0.3.2197+1.2.0-1_amd64.deb

In case any dependecy problems arise (which did in my case), use

sudo apt-get -f install

This will successfully install a compatible version of Google Earth for your system.

Here's how Google Earth now looks:

(As opposed to how it looked on my PC as shown in the question)

How it should look now

Note: This method worked for me, hope it works out for you as well :)

(reference: https://help.ubuntu.com/community/GoogleEarth)

  • Is there a similar solution for the latest GE 7.3 release? – s6hebern Mar 17 '18 at 12:57
  • @s6hebern Not that I know of, sorry! – Kewal Shah Mar 17 '18 at 14:04
  • 2
    Google no longer publishes the installation file http://dl.google.com/earth/client/current/GoogleEarthLinux.bin required by this script. – Serge Stroobandt Oct 22 '18 at 7:24
  • Currently (2019-06-11), the only way to make Google Earth Pro work in such case consists of uninstalling its newest version, then downloading google-earth-pro-stable_7.1.8.3036-r0_amd64.deb straight from Google's official repository (dl.google.com/linux/earth/deb/pool/main/g/…) and finally installing it. If e.g. you have gdebiinstalled (sudo apt-get install gdebi -y) and you saved such DEB package in /tmp, just run sudo gdebi -n /tmp/google-earth-pro-stable_7.1.8.3036-r0_amd64.deb and you're good to go. – Yuri Sucupira Jun 11 '19 at 5:48

Option 1: Install an older Google Earth Pro version

The latest versions of google-earth-pro are not compatible with GNU/Linux drivers for newer graphics hardware.

Uninstall the latest google-earth-pro version, then download and install google-earth-pro-stable_7.1.8.3036-r0_amd64.deb from the official or a private backup repository, as suggested here.

In the Synaptic Package Manager, select PackagesLock Version to prevent future upgrading.

Option 2: Modesetting DDX

If the xserver-xorg-video-intel package is in use, and your Intel integrated graphics is rather new, simply uninstall it and reboot.

$ sudo apt remove xserver-xorg-video-intel

As the information packaged with the driver explains:

The use of this driver is discouraged if your hw is new enough (ca. 2007 and newer). You can try uninstalling this driver and let the server use it's builtin modesetting driver instead.

Option 2 caveat

Unfortunately, modesetting DDX breaks many other things:

See also archlinux.org.

  • 1
    Thank you! I would never have run across that "is discouraged" on my own, and it fixed both Google Earth and 3D in my browser. The other answer didn't help at all, but this one is perfect. – Brandon Rhodes Jan 17 '19 at 17:53
  • 1
    Excellent answer. This worked for me (I opted for option 2). Thank you so much. – A. Stroh Feb 14 '19 at 19:41
  • 1
    At least till 2019-06-11 you could still download google-earth-pro-stable_7.1.8.3036-r0_amd64.deb straight from Google's official repository: dl.google.com/linux/earth/deb/pool/main/g/… – Yuri Sucupira Jun 11 '19 at 5:40
  • Another Option 2 caveat: I experienced annoying screen tearing and couldn't find a solution. Instead of removing the Intel driver, it's now enough to reconfigure it. See my answer. – kontextify Dec 18 '20 at 10:28

As of this writing, you don't need to remove xserver-xorg-video-intel to run the latest Google Earth. Simply enable dri3 in your Intel graphics config:

/etc/X11/xorg.conf.d/20-intel-graphics.conf (create if needed):

Section "Module"
   Load "dri3"

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"

   # Fixes Google Earth. Requires dri3 module:
   Option      "DRI"   "3"

   # OPTIONAL, but fixes screen tearing for me:
   Option      "TripleBuffer" "true"
   Option      "TearFree"     "true"

Restart. Works on Ubuntu 18.04 + Intel HD Graphics 4000 (IVB GT2).

Not the answer you're looking for? Browse other questions tagged or ask your own question.