I have the same problem as is described here but that question does not have an answer and its OP does not seem like they will ever answer the arisen questions.

I installed google-earth-pro-stable_current_amd64.deb via sudo apt install on Ubuntu 16.04 64 bit.

Deleting ~/.xinputrc did not change anything. When I log into a different account (account on my machine, that is – I do not think the commenter meant a different Google account (I did not log into any Google account)), I experience the exact same problem.

It is not like a glitch which occurs for a few seconds and then vanishes. Google Earth just is not usable because the map never shows up. It always shows the controls, part of the splash screen, and whatever was in the background when the application was launched.

What shows up when I launch Google Earth:

ttf-mscorefonts-installer already was installed.

Using gdebi didn't resolve the problem either.

Neither did using the 32 bit version.

  • Having installed the .deb from Google, I've also tried the Safe mode graphics, to no avail.
    – carnendil
    Commented Oct 18, 2017 at 0:27
  • Also, this seems to be a duplicate of askubuntu.com/q/956464/58950 which, although it might appear as abandoned, it's only one month old.
    – carnendil
    Commented Oct 18, 2017 at 0:38
  • @carnendil I linked to that question in the very first paragraph. I did, however, not see that it's "only" abandoned for a month but a year. Somehow, I read the date as "September 2016", not "September the 16th".
    – UTF-8
    Commented Oct 18, 2017 at 10:15
  • I also thought it was "September 2016" the first time :). That's why I made the "duplicate" comment only later. I haven't found a solution to question yet.
    – carnendil
    Commented Oct 20, 2017 at 15:13
  • @UTF-8 , I am experiencing the same problem, even installing the 32-bit version didn't work. I was going to ask this as a separate question but found this question to be having exactly what I wanted to ask. If you've already found the solution by now please answer your own question, if not I am hopeful people viewing this will be able to find a solution to it soon.
    – Kewal Shah
    Commented Oct 30, 2017 at 19:56

3 Answers 3


I have found the solution to the problem:

Find the currently installed Google Earth package

dpkg --list 'google-earth*'

Uninstall the existing package:

sudo dpkg -P google-earth-stable

Install the googleearth-package package:

sudo apt-get install googleearth-package

Use the script to download the latest binary and create a .deb package:

make-googleearth-package --force

An example of the message you should get after executing the above command:

Description: Google Earth, a 3D map/planet viewer
 Package built with googleearth-package.
dpkg-deb: building package 'googleearth' in './googleearth_6.0.3.2197+1.2.0-1_amd64.deb'.
You can now install the package with e.g:

sudo dpkg -i googleearth_6.0.3.2197+1.2.0-1_amd64.deb

Install the .deb package as mentioned in the description:

sudo dpkg -i googleearth_6.0.3.2197+1.2.0-1_amd64.deb

In case any dependecy problems arise (which did in my case), use

sudo apt-get -f install

This will successfully install a compatible version of Google Earth for your system.

Here's how Google Earth now looks:

(As opposed to how it looked on my PC as shown in the question)

How it should look now

Note: This method worked for me, hope it works out for you as well :)

(reference: https://help.ubuntu.com/community/GoogleEarth)

  • Is there a similar solution for the latest GE 7.3 release?
    – s6hebern
    Commented Mar 17, 2018 at 12:57
  • @s6hebern Not that I know of, sorry!
    – Kewal Shah
    Commented Mar 17, 2018 at 14:04
  • 2
    Google no longer publishes the installation file http://dl.google.com/earth/client/current/GoogleEarthLinux.bin required by this script. Commented Oct 22, 2018 at 7:24
  • Currently (2019-06-11), the only way to make Google Earth Pro work in such case consists of uninstalling its newest version, then downloading google-earth-pro-stable_7.1.8.3036-r0_amd64.deb straight from Google's official repository (dl.google.com/linux/earth/deb/pool/main/g/…) and finally installing it. If e.g. you have gdebiinstalled (sudo apt-get install gdebi -y) and you saved such DEB package in /tmp, just run sudo gdebi -n /tmp/google-earth-pro-stable_7.1.8.3036-r0_amd64.deb and you're good to go. Commented Jun 11, 2019 at 5:48

This disappearing map problem occurs on computers with Intel graphics running xserver-xorg-video-intel and Google Earth Pro versions that are more recent than google-earth-pro-stable_7.1.8.3036-r0_amd64.deb.

Make sure xserver-xorg-video-intel is installed:

$ sudo apt install xserver-xorg-video-intel

On (X)Ubuntu LTS 20.04, the problem can be resolved by editing the following file. Create it if it is not present.

$ sudo nano /etc/X11/xorg.conf

Add the Direct Rendering Infrastructure dri3 as a "Module" and append three evocation lines to the "Device" section. Leave other sections unchanged. If your xorg.conf file happens to be empty, copy the whole lot.

Section "Module"
   Load "dri3"

Section "Device"
    Identifier      "Device0"
    Driver          "intel"
    Option          "Backlight"      "intel_backlight"

    # DRI 3 evocation lines below
    Option      "DRI"   "3"
    Option      "TripleBuffer" "true"
    Option      "TearFree"     "true"

Section "Monitor"
    Identifier      "Monitor0"

Section "Screen"
    Identifier      "Screen0"
    Monitor         "Monitor0"
    Device          "Device0"

Do not forget to reboot. After rebooting, recent Google Earth Pro versions should work fine; including street view.

  • 1
    Thank you! I would never have run across that "is discouraged" on my own, and it fixed both Google Earth and 3D in my browser. The other answer didn't help at all, but this one is perfect. Commented Jan 17, 2019 at 17:53
  • 1
    Excellent answer. This worked for me (I opted for option 2). Thank you so much.
    – A. Stroh
    Commented Feb 14, 2019 at 19:41
  • 1
    At least till 2019-06-11 you could still download google-earth-pro-stable_7.1.8.3036-r0_amd64.deb straight from Google's official repository: dl.google.com/linux/earth/deb/pool/main/g/… Commented Jun 11, 2019 at 5:40
  • Another Option 2 caveat: I experienced annoying screen tearing and couldn't find a solution. Instead of removing the Intel driver, it's now enough to reconfigure it. See my answer.
    – kontextify
    Commented Dec 18, 2020 at 10:28

As of this writing, you don't need to remove xserver-xorg-video-intel to run the latest Google Earth. Simply enable dri3 in your Intel graphics config:

/etc/X11/xorg.conf.d/20-intel-graphics.conf (create if needed):

Section "Module"
   Load "dri3"

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"

   # Fixes Google Earth. Requires dri3 module:
   Option      "DRI"   "3"

   # OPTIONAL, but fixes screen tearing for me:
   Option      "TripleBuffer" "true"
   Option      "TearFree"     "true"

Restart. Works on Ubuntu 18.04 + Intel HD Graphics 4000 (IVB GT2).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .