0

After a recent upgrade (including Ubuntu proposed repo) this command started failing:

docker -D build .

It failed at random lines in my Dockerfile on things like setting an environment variable:

failed to export image: failed to set parent
sha256:1209386865e4a395004592f49943a2ceee54f9b77800062b1fcd48b7ce58b592: 
unknown parent image ID 
sha256:1209386865e4a395004592f49943a2ceee54f9b77800062b1fcd48b7ce58b592

failed to get digest
sha256:2630e04441b4f54a6f2df481ecac83071fa89078c192de90be1ffb9069806964: 
open 
/var/lib/docker/image/overlay2/imagedb/content/sha256/2630e04441b4f54a6f2df481ecac83071fa89078c192de90be1ffb9069806964:
no such file or directory

Normally in severe cases of possible corruption I do the below but this time it didn't help:

service docker stop
/var/lib/docker/
service docker stop
1

After days of struggling, I finally laid my hands on it and figured out that the poppler packages was somehow responsible, I removed them:

libpoppler58:amd64 0.41.0-0ubuntu1.4
poppler-utils:amd64 0.41.0-0ubuntu1.4
libpoppler-glib8:amd64 0.41.0-0ubuntu1.4
libpoppler-qt4-4:amd64 0.41.0-0ubuntu1.4
libpoppler-qt5-1:amd64 0.41.0-0ubuntu1.4

restarted docker and then it worked \o/

Update:

I tried version 0.41.0-0ubuntu1.4 (security repo) today but that also broke it and then reverting back to 0.41.0-0ubuntu1 fixed it again.

Update:

I tried version 0.41.0-0ubuntu1.5 of poppler-utils:i386 and libpoppler58:i386 (security repo) today but that also broke it and then reverting back to 0.41.0-0ubuntu1 but now it is still broken :'( . In the end I uninstalled docker-ce and re-installed docker.io and that worked \o/. (I even tried the snap version of docker but unfortunately I could not get it to work, with all of it's quirks)

| improve this answer | |
  • see my other answer that finally laid this to rest.. – AmanicA Jan 5 '18 at 15:51
0

I still had these issues on and off until now when in an answer to my prayers Anthony Farquharson sugested I try the following before trying a complete re-install:

apt remove docker-ce 
apt purge docker-ce 
apt purge docker.io 
# delete all docker configs in /etc 
# doublecheck apt repo for docker
apt install docker-ce 
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.