2

I am looking to calculate BLAKE2 hashes for files on my Ubuntu 16.04 machine. I would like something similar to md5sum or sha512sum for BLAKE2, however have not found a package in the Ubuntu repositories that provides this functionality.

It seems that the "b2sum" command is provided in coreutils version 8.26 and newer, which presumably does this, however 16.04 has verion 8.25. This functionality does not appear to be in the versions of hashdeep or hashrat in 16.04 either.

As such, I tried installing the libb2-1 package. Unfortunately it does not seem to provide the "b2sum" command (as the libdigest-sha3-perl package does with the sha3sum command).

Is there a package that provides a command I can run to obtain BLAKE2 hashes in the Ubuntu 16.04 (xenial) repositories?

2

It was a bit difficult, but I found it by looking at the man page:

http://manpages.ubuntu.com/manpages/xenial/man3/blake2.3.html

Provided by: libb2-dev_0.97-2_i386

so https://launchpad.net/ubuntu/xenial/+package/libb2-dev

But you probably do not want the -dev package, so searching for libb2 got me to

https://packages.ubuntu.com/zesty/libb2-1

so

sudo apt install libb2-1 #I assume, could be libb2

If you are not running zesty , I advise you compile from source:

See https://superuser.com/questions/808553/blake2-installation-in-linux

UPDATE : After further research ...

blake2 was incorporated into coreutils , see https://lists.gnu.org/archive/html/coreutils/2015-05/msg00060.html

So b2sum is part of coreutils

From FEDORA

bodhi@daemon:~$which b2sum
/usr/bin/b2sum
bodhi@daemon:~$dnf provides /usr/bin/b2sum

coreutils-single-8.27-5.fc26.x86_64 : coreutils multicall binary
Repo        : fedora
Matched from:
Filename    : /usr/bin/b2sum

After further searching Ubuntu packages :

https://packages.ubuntu.com/search?suite=zesty&arch=any&searchon=contents&keywords=b2sum

b2sum is available in coreutils starting in zesty (17.04) but not in xenial.

  • I ran apt-get install libb2-dev which also installed libb2-1, however am still unable to run b2sum or blake2s from the terminal. It returns "command not found". Also, as indicated in the question, I am running 16.04 (Xenial Xerus). – DougC Oct 17 '17 at 14:53
  • Should be b2sum . Try tab completion (b2<tab> or b2sum<tab>) . the binary may be b2sum-bin or you may need to file a bug report. – Panther Oct 17 '17 at 15:16
  • Using dpkg -L libb2-1 I see 4 files installed (copyright, changelog.Debian.gz, libb2.so.1 and libb2.so.1.0.2) and for libb2-dev there are 6 (copyright, changelog.Debian.gz, blake2.3.gz, libb2.a, blake2.h and libb2.so). The b2sum executable does not seem to have been installed. Does your 16.04 system provide a different result? – DougC Oct 17 '17 at 15:25
  • 1
    @DougC - See update to answer, it is in coreutils but not in the ubuntu repost until zesty (17.04) – Panther Oct 18 '17 at 3:36

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.