0

This question already has an answer here:

I have installed Ubuntu alongside windows 8.1 on my Sony laptop. after installation i am able to login Ubuntu,but if i login to windows after that grub not showing,its directly login to windows. I have tried boot repair with recommended repair option in boot-repair ISO and also i tried the following command bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi. But am facing the same problem.Can any one help to resolve this issue.

marked as duplicate by Rod Smith uefi Oct 17 '17 at 19:35

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    do you have Fast Startup disabled in windows? – ravery Oct 16 '17 at 15:35
  • Yes I have disabled – Venkat Oct 17 '17 at 4:13
1

EFI expects the default boot loader to be /efi/boot/bootx64.efi.And, Windows is particular about making sure it boots.

First off, from 8.1 on windows does not really shut down, it suspends to disk ( like a hibernate) so that it boots faster. Second it changes EFI to make entry 0000 (windows) first in the boot order.
First be sure that "Fast Startup" is disabled in Windows. If that doesn't solve the issue do the following work around,

Open the EFI partition on the HDD and copy /EFI/BOOT/bootx64.efi to /EFI/windows folder in case you want it later. (this is the Windows bootloader)
Next copy /EFI/ubuntu/shimx64.efi to EFI/BOOT and rename to bootx64.efi, this makes grub the default boot loader. (if you are not using secure boot then copy and rename grubx64.efi)

When in ubuntu, install efibootmgr. Use efibootmgr to delete all efi entries except the netboot.
Then reboot your computer. Make sure the first system you boot into is ubuntu so that it is placed in entry 0000. then boot windows.

  • In EFI partition Ubuntu Folder is empty in this laptop – Venkat Oct 17 '17 at 5:44
  • @Venkat -- you need to install grub – ravery Oct 17 '17 at 10:02
  • @ravery-- i tried with boot-repair iso... after that also Ubuntu folder is empty.. – Venkat Oct 17 '17 at 13:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.