I'm very much used to the Windows+Number shortcuts from Windows. Unity allows me to keep this habit, but it doesn't work very reliably for me.

The problem is that sometimes instead of switching windows, the currently active window receives the number input and then the unity search opens. After closing the search and undoing unwanted edits, the second time the shortcut always reliably works.

At first I thought that I wasn't hitting the keys in the right order or not holding the Windows key long enough, but as I got slower and more careful over many weeks, the issue would not disappear.

At this point, asking this question might be more time efficient than enduring this behavior (depending on the answers!).

Is there a way to improve the reliability of this keyboard shortcut? It seems to me that some background listening service is asleep and misses the keys, because it always works the second time.

  • 1
    Does hitting <Number> key right after Super make difference ? In my case this behavior trigger if I press those key at a same time. – Emmet Oct 23 '17 at 11:25

Simply holding down the Super key until the numbers show up on the icons as shown below works fine under Ubuntu 14.04:

enter image description here

Another possibility is that you may have modifications that are impacting the speed at which the number choices appear when you hold down the Super key. These can be reset to defaults. dconf reset -f /org/compiz/&&setsid unity Or more drastically as a last resort reset all your dconf settings back to defaults with mv .config/dconf/user .config/dconf/user.bak&&sudo reboot

the Super key is used for several things (bringing in the launcher if it's hidden, opening the dash, bringing up the keyboard shortcuts, and in combination with other keys a long list of functionality and so this is almost certainly a timing play.

  • Thanks for you suggestions. The number only show up after holding the Super key for a full second, which makes it impractical as a shortcut. When it works, it does so even before the numbers show up. I'll do some testing with the dconf settings. – typ1232 Oct 30 '17 at 8:08
  • @typ1232 I had similar results but I didn't want to state "full second" as I assumed that system performance and system load could have an impact on delay. – Elder Geek Oct 30 '17 at 17:03

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.