26

I'm in 17.10. Whenever I touch the screen, whether to change windows/apps, scroll within a browser, or press a button, the stupid little keyboard pops up in the bottom left corner.

I have never left Screen Keyboard enabled in Universal Access, but if I toggle it on, that's the same keyboard popping up in the bottom left corner.

screenshot of keyboard taking over

In this screenshot, I'm simply touching the screen in a full-screen youtube video. You can see the menu pop up on the right, under the point where I'm touching.

I don't have a before pic, but it was similar look/color keyboard, but it was smaller, maybe half as wide, and only in the bottom left section of the screen, as opposed to stretching across the entire width. This change from little left-hand keyboard to full-width keyboard happened after following @pomsky 's advice below.


This is a confirmed bug. You can mark yourself affected by it to hopefully increase its received attention.

3
  • 1
    Further, the use of link shorteners is against Ask Ubuntu policy. Linking to the direct bug itself as was done in the edits that were done to your question is improvement of the question per policy. (We do not like link shorteners as there is no way to verify that it's actually going to a 'legitimate' page that won't infect a system with malware, or something.) Also, advertising an extension that would be a workaround should be its own answer, not an edit to the question. Or posted as a comment, like I've done for you. – Thomas Ward Feb 2 '18 at 16:54
  • To all: OP recommended that there might be a workaround located here that might work: askubuntu.com/a/967831 – Thomas Ward Feb 2 '18 at 16:58
  • I am also affected by this bug; not only that but sometimes my mouse cursor goes crazy and I can't scroll anywhere; the only solution for me at that point is to hard reset my rig. – MadHatter Jun 21 '19 at 4:12
33

Caribou also kept popping up to my great annoyance, so I wrote a gnome extension that monkey patches gnome-shell to stop popping up the keyboard when the touchscreen is pressed.. It's only a couple of lines of js, but the git repo is here

How to use extensions

  1. To manage gnome extensions, download gnome-tweak-tool with

    sudo apt install gnome-tweak-tool
    
  2. Gnome extensions are downloaded through the official gnome-extensions website, which requires a native connector to communicate with gnome-shell. Install this native connector (even if you're running Firefox) with

    sudo apt install chrome-gnome-shell
    
  3. Finally to install the extension, go to the extension's page and hit the switch in the top right corner. Gnome will than prompt you to install the extension. These extensions can be managed through the gnome tweak tool. However, to uninstall them, you must use the web page.

6
  • 1
    Very odd behavior with your extension, while I can do web page window bar scrolling, and touch-and-drag scrolling on the page itself (not the bar), some forms of touch-and-drag are disabled by the extension! I can no longer touch-and-drag chess pieces on chess.com. Really bizarre little side effect! – Tom Mercer Oct 29 '17 at 5:55
  • 1
    I'll try and take a look. I have an idea of what could be happening. The extension overwites gnome shells touchscreen detection. But I don't see how that would affect the web browser. I'll test out some changes once I finish up my midterms – Keringar Oct 30 '17 at 6:36
  • 1
    No worries. Probably not worth your time. Thanks for creating the extension. If the reason doesn't occur to you right off the bat, just ignore it. They need to fix GNOME properly so we don't have to use this band-aid solution. – Tom Mercer Oct 30 '17 at 16:36
  • 1
    I'm so puzzled by this side effect. I can't imagine why touch-and-drag would be disabled by killing Caribou. So bizarre! – Tom Mercer Nov 11 '17 at 3:57
  • 1
    I am in 18.04, same problem, no idea what should I do after the install of the two programs... – jaromrax May 2 '18 at 14:03
1

I'm running Ubuntu 16.04 and had a similar problem when running Synergy. Sometimes the on-screen keyboard would pop up for no reason and I couldn't get it to go away. I finally decided to just remove Caribou:

sudo dpkg --remove --force-depends caribou
ps -eF | grep caribou | awk "{print $2}" | xargs kill -9 {}+ 

That left the keyboard still stuck on the screen, but I locked the screen (crtl+alt+L) and logged back in, then the keyboard dropped away.

Not the answer you're looking for? Browse other questions tagged or ask your own question.