1

hope this is a simple one for you experts. Been trying to get the configuration going for OpenVPN and keep hitting the same wall:

when I enter this command './build-ca', I get the following:

error on line 198 of /etc/openvpn/easy-rsa/openssl-1.0.0.cnf 139967340545688:error:0E065068:configuration file routines:STR_COPY:variable has no value:conf_def.c:584:line 198

The commands I have used are from the guide:

sudo apt install openvpn easy-rsa
mkdir /etc/openvpn/easy-rsa/
cp -r /usr/share/easy-rsa/* /etc/openvpn/easy-rsa/

then edit /etc/openvpn/easy-rsa/vars

export KEY_COUNTRY="XX"
export KEY_PROVINCE="XX"
export KEY_CITY="XXX"
export KEY_ORG="Example Company"
export KEY_EMAIL="xx@xx.com"
export KEY_CN=MyVPN
export KEY_NAME=MyVPN
export KEY_OU=MyVPN

cd /etc/openvpn/easy-rsa/
source vars
./clean-all
./build-ca

I have used the guide from Ubuntu: https://help.ubuntu.com/lts/serverguide/openvpn.html

Been using PuTTY from my Windows 10 system and doing a copy and paste to ensure no typos but not working. Fairly new to Linux server, have been playing around with Ubuntu 16.04 and CentOS 7 but have not had much luck with either.

My goal is to have a Linux Server setup in my home office and allow remote users to be able to access it to upload files, and eventualy have others access data files with tight restrictions, probably via FTP. PureFTP has worked very well but I need remote users to be able to access this server. What am I missing???

Thanks for your help!

Ps, also tried the guide from here:

https://www.howtoforge.com/tutorial/openvpn-secure-server-administration/

But it appears to be missing some steps as it advises to do this: apt-get install openvpn nano /etc/openvpn/server.conf But there is no server.conf file!

  • Are you trying to install an OpenVPN server or just set up a client? If the former, and you have no server.conf, you have gone badly astray somewhere. – Organic Marble Oct 15 '17 at 22:39
  • I used this tutorial to set up my server: digitalocean.com/community/tutorials/… – Organic Marble Oct 15 '17 at 22:41
  • You left the server name in vars "server"? Look for the name you used. The tutorial looks pretty similar to the digitalocean one as far as the ./build-ca anyway. – ubfan1 Oct 15 '17 at 22:47
  • I'll have a look at the Digital Ocean guide, thanks Organic Marble – David Oct 15 '17 at 23:03
  • ubfan1, where are you seeing this? – David Oct 15 '17 at 23:03
0

Add the following line to the vars file: export KEY_ALTNAMES="Anythingyouwish"

And then follow the process for ./build-ca

Good Luck

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.