4

I have a strange problem with all Samsung printers with Wi-Fi connection. When I try print some docs, pdf etc., printer prints some strange code.

enter image description here

I have installed Samsung driver.Is someone else having this problem?

Ubuntu 17.04, Dell XPS 13 9360

2
  • What happens when you print images? Are there any things that print correctly?
    – brndn2k
    Oct 15 '17 at 17:34
  • And what if you print a file with a few lines of text (like made with gedit or vi), not using non-plain text files like Office files or pdf files. The files you describe are not plain ascii text. They have non-printing control characters in them and it looks like your driver/printer are treating them as ascii text and so you get what you see.
    – jpezz
    Oct 16 '17 at 1:51
6

I had the same problem with my Samsung printer (Xpress C460w). The following solved for me:

I went to printers -> additional printer settings-> add new window opens: go to network printer wait for a few seconds until your printer will be found, and click on it. On the right bottom as connection chose:

LPD network printer via DNS-SD

New printer

(for me Appsocket/HP Jetdirect also worked only the "Driverless IP" one made that code by printing)

Click on forward, wait a sec until the driver will be added, and print the test page to see if it worked

1
0

Using the original Samsung's driver helped me. I couldn't force my Elementary OS to use the right PPD file so I replaced the file in /etc/cups/ppds directly and restarted CUPS daemon.

cp uld/noarch/share/ppd/Samsung_C48x_Series.ppd ppd/Samsung_C48x_Series_on_192.168.1.100.ppd
sudo systemctl restart cups

It's not flawless, I can't print something like 10 MB photo, but still better than a pile of paper covered by nonsense.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.