10

Anyone know how to resolve this?

I have a Thinkpad W520 running 17.04 upgraded not fresh install

photo of the error message on black screen]

I have two disks on my laptop /dev/sda (which is original Windows not my Ubuntu) and /dev/sdb which is my mPCIe that has Ubuntu.

Can anyone confirm whether I need to grub-install /dev/sdb to resolve this error?

Please note I can safely boot when I hit enter as it shows GRUB with list of selections to select Ubuntu and boot.

This has been the case without error since Ubuntu 14 or 15 and I've been upgrading all the way, and when I upgraded to 17.04 this started to show.

2
  • Google search....In the end, I fixed it by re-installing GRUB using the Trisquel liveCD. However, I have the problem I tried to fix before: running `update-grub' finds other Operating Systems, but asks for a username and password when I select them (but does not do this for Trisquel) despite me having not set a GRUB password lock. – EODCraft Staff Oct 15 '17 at 11:32
  • 1
    You may be affected by this bug – Elder Geek Jul 16 '18 at 20:26
18
sudo fdisk -l

This will list all partitions on your HDD (find under Type section the Ubuntu or Linux and its Device (like /dev/sda)) then, do

sudo grub-install /dev/sda

note that is sda and NOT sda1

sudo update-grub
sudo reboot
2
  • this answer applies to Legacy Boot and MBR disk. It is quickly becoming outdated as EFI and GPT are becoming the standard. – ravery Oct 27 '17 at 0:29
  • My old system is still BIOS-based (so no EFI/UEFI) but I'm already using GPT disks. I've been using gdisk for the partitioning, but the above fdisk command does work as expected (at least on Ubuntu 18.04). So it is not yet outdated :-) – Huygens Sep 27 '18 at 18:42
2

I also got this error after installing Kubuntu 18.04. For me the solution was to remove an old, invalid boot entry from EFI that was booted by default, but never got updated by update-grub.

Run sudo efibootmgr and look for multiple Linux/Ubuntu entries, then delete outdated ones by following this answer: How do I remove "Ubuntu" in the bios boot menu? (UEFI)

1
  • 1
    EFI variables are not supported on this system. – Bashar Al-Abdulhadi Jul 18 '18 at 16:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.