Hello there. I am new in Ubuntu and I just installed python 3.6 and was happy about it but suddenly i noticed that I cant open terminal anymore. I used the shortcut before, but now it just doesn't work! I tried run Terminal from application but it just shows icon in task bar and then just goes away, nothing happens. But the weirdest thing is I can open it from folder and it is working just fine.

I thought it was caused by some my personal setting but in ~/.gconf I don't have any other folder so i can't delete some Terminal settings.

Hope someone knows what is going on.

  • Try with ALT + F2 and type gnome-terminal and see if it launches that way – userDepth Oct 14 '17 at 20:52
  • And try not to go on deleting files because a program doesn't work, what you can do is reinstall the program by entering the tty. CTRL + ALT + F1 takes you to it and you type your user login and password, then you can use the terminal session to reinstall from there. – userDepth Oct 14 '17 at 20:54
  • I tried everything actually. ALT+F2 gnome-terminal didn't work. I also removed terminal and installed it again but still can't start it by normal way. For now I'm using it by opening from home folder and it works well, but i guess this problem is temporary and i will find cure soon. – Nikita Glukhov Oct 15 '17 at 18:58

I met the same problem. I solved it by

sudo nano /usr/bin/gnome-terminal

and change #!/usr/bin/python3 to #!/usr/bin/python3.6. I changed to 3.7 at first as I installed it, but it didn't work. It only works after I changed to 3.6. Refer to this


You might have a compatible issue for the gnome-terminal Python script in your Ubuntu versus the newly installed python 3.6. Please refer to this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.