0
fsck /dev/sda1  -->/bin/bash: Output: not found

enter image description here

  • Follow my answer at this issue, see if it works. – Redbob Oct 14 '17 at 12:43
  • 1
    boot from a livecd, and paste the contents of et/fstab in your question. your root file system should be mounting as "/" not "/root" – ravery Oct 14 '17 at 12:56
1

Remove HDD from system connect it to another system on second SATA port alongside with that HDD and turn ON system

Open terminal

Find the device label of that HDD using

sudo lsblk

for example if it is /dev/sda1 then run below command in terminal

If fsck is not working then try

sudo e2fsck -f -b 32768 -y /dev/sda1
  • 1
    Please cheak answer once again – Mayur Bhandare Apr 6 '18 at 7:13
  • e2fsck Checks and repairs a disk, as does fsck and -f and -b will cheak forcefully superblocks. – Mayur Bhandare Apr 6 '18 at 11:34
  • 2
    I have similar problem i can't even get e2fsck to work its not found too – Raghvendra Singh Mar 10 '19 at 19:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.