0

This question already has an answer here:

I'm on win10 64bit on an ACER laptop and I'm trying to dual boot ubuntu MATE 16.04.3 alongside it. However on startup it still always boots into windows. System info says I'm booting windows in UEFI. This is my boot-repair report from try ubuntu.

This is what I've done so far:

  1. I have an SSD and HDD, and I started by shrinking around 400GB from my HDD.
  2. Then I used rufus with the ubuntu-mate-16.04.3-desktop-amd64.iso to make my USB flash drive a bootable one.
  3. I disabled fast boot from my power settings in windows, and I didn't seem to be able to find it in BIOS. In BIOS I have a supervisor password, my settings were set to UEFI on secure boot.
  4. I booted from my usb and accidentally chose the install ubuntu option at first and got a file not found error and exited to try again, this time from the try ubuntu option to install ubuntu from there.
  5. I connected to my wifi within the live version and ran the install process there. I ticked both boxes for installing updates and third party software. As secure boot was enabled, I entered a password in.
  6. I simply chose the install ubuntu alongside windows boot loader option.
  7. Then I restarted the laptop from ubuntu once it was done. It didn't boot into ubuntu or give me a choice, going straight to windows.
  8. I've tried turning off secure boot and running boot-repair within the live ubuntu running from my usb, as well as moving up my HDD to the top of the boot load order and running the bcedit cmd as suggested by boot-repair. None of these worked!
  9. In disk management in windows I now have 3 partitions alongside my windows partition in my HDD replacing the 400GB shrinked unallocated space from the start, however they all say they have 100% free space. Are they supposed to be like that? Maybe I should clear the partitions and reinstall or something?

This is my first go at natively installing anything linux after I've been using them in vms with no problems, except that it ran too slowly.

Edit: I don't believe this is a duplicate as I've got a specific situation that I'm having problems with, and it seems like I've gone through the steps given in that post already.

marked as duplicate by Panther, Kevin Bowen, pa4080, Eric Carvalho, George Udosen Oct 14 '17 at 16:00

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • See the "troubleshooting" section first answer - "TROUBLESHOOTING YOUR COMPUTER BOOTS DIRECTLY TO WINDOWS This is a common problem and if you do not get a GRUB menu , re-installing or repairing grub will NOT HELP" – Panther Oct 13 '17 at 15:45
  • @bodhi.zazen I don't see ubuntu in the boot section of my bios, just my drives and windows boot manager – James Oct 13 '17 at 16:24
  • @bodhi.zazen the boot order section I mean – James Oct 13 '17 at 16:31
  • Did you create an UEFI password & enable "trust"? askubuntu.com/questions/771455/… & askubuntu.com/questions/908854/… & askubuntu.com/questions/627416/… – oldfred Oct 13 '17 at 23:40
  • @oldfred thanks a lot! that was it. I didn't think that the acer bios would be the problem, as it wasn't mentioned when I was looking up how to do it. All i saw was that it was supposed to be uefi and secure boot compatible! – James Oct 14 '17 at 0:56
0

Thansk to @oldfred, it turns out I needed to use custom secure boot settings in my acer bios.

as per this answer that he linked:

Press F2 to enter into BIOS and do following:

  • Set supervisor password from Security menu option.

  • Set BootMode to 'UEFI' from Boot menu option.

  • Enable SecureBoot from Boot menu option.

  • From Security menu option - Select 'UEFI file as trusted for executing' press Enter then 'HDD0' appears press Enter then 'EFI'
    appears press Enter then select 'ubuntu' option from the list (only
    listed if you have ubuntu installed already) press Enter then choose
    'shimx64.efi' (In my case it's the third entry) press Enter give it a name and press Enter.

  • Go back to Boot menu option and under Boot priority goto 'ubuntu' item in the list and press F6 until it become top most item
    in the list. Repeat same for 'Windows Boot manager' until it becomes
    second top most item in the list.

  • Press F10 to save changes and exit.

and it works!

Not the answer you're looking for? Browse other questions tagged or ask your own question.