1

I am facing issues with running apt-get update and apt-get install on my system. This is after deleting squid, iptables and dansguardian. I was trying to install DansGuardian, and ran the following commands:

sudo apt-get install iptables dansguardian squid
sudo gedit /etc/squid/squid.conf 
sudo /etc/init.d/squid restart 
sudo gedit /etc/dansguardian/dansguardian.conf 
sudo apt autoremove dansguardian 
sudo apt-get install iptables dansguardian squid
sudo gedit /etc/dansguardian/dansguardian.conf 
sudo /etc/init.d/dansguardian start 
sudo gedit /etc/init.d/tproxy
sudo update-rc.d tproxy
sudo apt-get install iptables

For reference I followed this link: Dansguardian Content Filtering With Transparent Proxy On Ubuntu 9.10 Karmic

Due to some difficulties with preinstalled software, I tried deleting squid, iptables and dansguardian, and restarting the process. sudo apt autoremove iptables dansguardian squid

Since then, I have not been able to reinstall any of the mentioned packages.

dell@dell-Inspiron-5558:~$ sudo apt-get install squid
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
libdbi-perl libecap3 libnetfilter-conntrack3 libnfnetlink0 squid-common
squid-langpack
Suggested packages:
libmldbm-perl libnet-daemon-perl libsql-statement-perl squidclient squid-cgi
squid-purge smbclient ufw winbindd
The following NEW packages will be installed:
libdbi-perl libecap3 libnetfilter-conntrack3 libnfnetlink0 squid
squid-common squid-langpack
0 upgraded, 7 newly installed, 0 to remove and 142 not upgraded.
Need to get 51.1 kB/3,322 kB of archives.
After this operation, 12.8 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Err:1 http://in.archive.ubuntu.com/ubuntu zesty/main amd64 libnfnetlink0 amd64 1.0.1-3
Could not connect to in.archive.ubuntu.com:80 (91.189.88.152). - connect (111: Connection refused) [IP: 91.189.88.152 80]
Err:2 http://in.archive.ubuntu.com/ubuntu zesty/main amd64 libnetfilter-conntrack3 amd64 1.0.6-2
Unable to connect to in.archive.ubuntu.com:http: [IP: 91.189.88.152 80]
E: Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/libn/libnfnetlink/libnfnetlink0_1.0.1-3_amd64.deb  Could not connect to in.archive.ubuntu.com:80 (91.189.88.152). - connect (111: Connection refused) [IP: 91.189.88.152 80]
E: Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/libn/libnetfilter-conntrack/libnetfilter-conntrack3_1.0.6-2_amd64.deb  Unable to connect to in.archive.ubuntu.com:http: [IP: 91.189.88.152 80]
E: Unable to fetch some archives, maybe run apt-get update or try with -fix-missing?

Also, some websites are not opening.

What could be the issue?

  • Did you try what it suggested, sudo apt update and sudo apt install --fix-missing? – dessert Oct 13 '17 at 7:01
  • Yes I tried it. I rerouted the proxy to pass through the one set up by dansguardian, and then deleted iptables. Do you think it is possible that internet filtering is blocking access to the locations apt-get install needs? – Giridhar Shyamkumar Oct 13 '17 at 7:18
  • Please provide the output of those commands in your question, each in a code block ({} button). – dessert Oct 13 '17 at 7:25
  • For the first; Reading package lists... Done Building dependency tree Reading state information... Done iptables is already the newest version (1.6.0-3ubuntu2). squid is already the newest version (3.5.23-1ubuntu1). dansguardian is already the newest version (2.10.1.1-5.1build1). The following packages were automatically installed and are no longer required: ... Use 'sudo apt autoremove' to remove them. 0 upgraded, 0 newly installed, 0 to remove and 142 not upgraded. – Giridhar Shyamkumar Oct 13 '17 at 7:44
  • For the second; ** (gedit:3106): WARNING **: Set document metadata failed: Setting attribute metadata::gedit-spell-language not supported ** (gedit:3106): WARNING **: Set document metadata failed: Setting attribute metadata::gedit-encoding not supported ** (gedit:3106): WARNING **: Set document metadata failed: Setting attribute metadata::gedit-position not supported As mentioned in the link, the line http_port 3128 is changed http_port 3128 transparent in the squid.conf file – Giridhar Shyamkumar Oct 13 '17 at 7:48
1

Run this command:

sudo apt-get -f install

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.