0

Did a fresh install of 16.04 and can see my wifi router as well as my neighbors'. When I put in the password, it won't connect and asks for the password again. Searched the web for answers:

  1. Tried the fix to stop the mac address changes,
  2. Restarted network-manager a bunch of times,
  3. Made sure the wireless driver was updated.
  4. Tried a usb install of 12.04; it wouldn't connect either.

Output of lspci command:

00:19.0 Ethernet controller [0200]: Intel Corporation 82566MC Gigabit Network Connection [8086:104d] (rev 03)
    Subsystem: Lenovo 82566MC Gigabit Network Connection [17aa:20ba]
    Kernel driver in use: e1000e
    Kernel modules: e1000e
00:1a.0 USB controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 [8086:2834] (rev 03)
--
03:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection [8086:4227] (rev 02)
    Subsystem: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection [8086:1010]
    Kernel driver in use: iwl3945
    Kernel modules: iwl3945
15:00.0 CardBus bridge [0607]: Ricoh Co Ltd RL5c476 II [1180:0476] (rev b6)
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

Added a post where I linked to the output file for the wireless-info script.

Tried to start the wifi using nmtui but it did the same thing.

Tried to copy and paste the password into network-manager, no difference.

See my comments below on the stuff I tried tonight.

  • Post network log – Amr Ayman Oct 13 '17 at 0:43
  • What happens when you type (from a command terminal) nmcli con wifi con [name of wifi network], replacing "[name of wifi network]" with the name of the network you want to connect to. (They may only work on 16.04.) Do you get any error messages? – TSJNachos117 Oct 13 '17 at 1:07
  • Comes back and says at the bottom 'wifi' is not valid 'connection' command – Jim Snider Oct 13 '17 at 1:18
  • @AmrAyman where is this network log? Jim Snider, we most likely need hardware information. Run the wireless info script and edit your question to post the results, please – Zanna Oct 13 '17 at 3:51
  • 1
    Please edit your question and add output of lspci -knn | grep Net -A3; rfkill list terminal command. – Pilot6 Oct 13 '17 at 8:42
0

Re-installed 16.04 last night with one big change. Found out that my router was set for 802.11n only. Reset it to allow older connections and wifi worked just fine.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.