0

I installed the new Ubuntu 16.04.3 LTS(64bit) and I used to have dual boot with Win 7(64bit) but after completing instalation only Ubuntu grub showed up: I tried sudo update-grub and I see that there still exist Windows 7 (loader) on /dev/sda2 how to bring it back because I have only ubuntu grub. I'm total newbie :((((

cezar@cezar-Lenovo-IdeaPad-Y580:~$ sudo update-grub

Generating grub configuration file ...

Found linux image: /boot/vmlinuz-4.10.0-28-generic
Found initrd image: /boot/initrd.img-4.10.0-28-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Found Windows 7 (loader) on /dev/sda2
Found Windows Recovery Environment (loader) on /dev/sdb1
done
cezar@cezar-Lenovo-IdeaPad-Y580:~$ /dev/sda2
bash: /dev/sda2: Permission denied
  • 4
    Possible duplicate of Unable to boot into Windows after installing Ubuntu, how to fix? – karel Oct 12 '17 at 16:21
  • Please run the Boot Repair utility and select the "Create BootInfo Summary" option. (DO NOT click "Recommended Repair," at least not yet!) When asked whether to upload the report, click "Yes," and then post the URL provided here. This will give us more details about your configuration, which is required to base an answer on more than guesswork. – Rod Smith Oct 12 '17 at 18:29
0

Problem solved. I typed all at once:

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install -y boot-repair && (boot-repair &)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.