1

I am running ubuntu 16.04 on a DELL and my computer got infiltrated by humidity when it was in sleep mode. When I turned it back on I had a BIOS panic message. It asked me to re-setup the BIOS (idk what this means) and then run diagnostics to detect hardware failures.

None were found. I ran the diagnostic tool multiple times and again all tests passed succesfully.

Therefore, I decided to boot normally my computer and after seeing the GRUB I am stuck with an initramfs shell. I understand that somehow somthing fails during the boot sequence and the kernel does not load.

I think it is because the boot does not find my SSD. Here is the error log I can manage to see when I type exit inside the initramfs shell.

Gave up waiting for root device. Common problems:
- Boot args (cat /proc/cmdline)
  - Check rootdelay= (did the system wait long enough?)
  - Check root= (did the system wait for the right device)
- Missing modules (cat /proc/modules; ls /dev)
ALERT! UUID=XXXXX does not exist. Dropping to a shell!

My newbie instinct in the field hopes that somehow the BIOS diagnostic/setup changed my disk UUID and thus Ubuntu does not find it. All hard drive tests in the BIOS indicate that I have no hardware problems.


Therefore my question is this: Would anyone of you have an idea of what my problem is? And if you have any idea, how do we fix this?


Additionally, here are the screenshots for cat /proc/modules enter image description here and for ls/dev we can see there is no /dev/sdaX thus no hard drive found enter image description here

5

I found my solution:

  1. I booted on a live USB Ubuntu.
  2. I could not see my hard drive, but switching on the BIOS the SATA Operations parameter from RAID to AHCI solved the problem. No idea why, maybe during the BIOS reset it switched the parameter, or maybe Ubuntu has trouble reading already-written-by-a-foreign-source RAID drives.
  3. At this point my original error was fixed but I got another one. I ran a manual fsck on my hard drive to address it.
  4. Everything works!
-1

https://help.ubuntu.com/community/Boot-Repair

  1. Boot your computer on a Ubuntu live-USB then choose "Try Ubuntu"
  2. Connect to the Internet
  3. Open a new Terminal, then type the following commands (press Enter after each line):

     sudo add-apt-repository ppa:yannubuntu/boot-repair
     sudo apt-get update
     sudo apt-get install -y boot-repair && boot-repair
    

This installs and runs Boot-Repair. Click "Recommended repair". After it has done its magic, write down the URL (paste.ubuntu.com/XXXXX) that appeared on a paper, then reboot and check if you recovered access to your OSs and can boot normally /without dropping to shell/.
If the repair did not succeed, indicate the URL to people who may help you by email or forum. You can also review it yourself and look over possible errors.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.