New Ubuntu user here... I have Ubuntu on my 250GB SSD and I have another 500GB on my laptop that Ubuntu can't find. I'm not sure where or how to start finding it.

  • Typing lsblk in a terminal window should return a list of all the partitions on your system, including ones that are not mounted. Oct 12, 2017 at 1:55

1 Answer 1


You might need to edit your /etc/fstab to mount your extra drive. Here's how you can check.

Type lsblk into a terminal like Organic Marble suggested. Devices named like sda, sdb, and sdc are going to be distinct drives, while sda1, sda2, etc are partitions of that drive.

If your drive isn't showing up in lsblk, then someone more experienced than I will need to answer your question. I'd guess it means that your drive isn't connected properly, but I don't know for sure.

However, if you do see a drive that's showing up in lsblk, but doesn't have a MOUNTPOINT, then we can likely assume that it's your drive, and we can follow a few simple steps to get it set up. Let's assume that your device is sdb.

First, figure out which partition of your 500gb drive you want to mount. If you have multiple partitions, then you'll need to do this for each partition. Let's assume you want sdb1.

Next, you need to figure out where you want to mount the partition to. I usually end up mounting all of my drives in the /media directory, with a subdirectory for the partition. for example, my local network share is mounted in /media/fileshare. Either way, decide where you want to mount this partition, and create a folder for it, like this: sudo mkdir -p /path/to/mount/directory.

Next you need to figure out the filesystem type. Type sudo parted -l to get a list of all drives connected to the computer. Find the drive in the list that matches your drive. The partitions will be listed starting at 1; note the column for 'file system'. Let's assume yours is ext4.

Now, open your /etc/fstab file with root permissions using your favorite text editor. Nano is pretty easy to use: sudo nano /etc/fstab. The fstab file contains information about all the drives that get mounted to your computer and tells the OS how and where to mount them. You should see a couple lines in there which correlate to your main drive as well as your swap space. You want to add a new line sort of like this one, but with whatever the values you came up with are:

# partition   mount location  filesystem  options   dump   pass
/dev/sdb1    /media/fileshare    ext4    defaults,     0    2

Where the defaults refers to all of the default options found here. I'm no expert on fstab options, but someone else might be able to help you more here.

Now, save and quit whatever text editor you used, and run the command sudo mount -a; this re-mounts all partitions found in fstab. Assuming you did everything right, your partition should be mounted, and you should be able to access your files from whatever mount point you specified in the fstab file.

  • Hey here's a screen shot of my terminal [i.imgur.com/YTboM8t.png]. I think "sdb" is the 500 gb hardrive with "core" (idk what that is). Oh on "loop1" I have the Atom that I can't run when I click the icon but runs when I 'sudo atom' in the terminal. Oct 12, 2017 at 4:36
  • Looks like sdb1 is the partition you want to mount. For sudo parted, you want to use -l (lowercase L), not -1 (the numeral one).
    – carusot42
    Oct 12, 2017 at 15:38
  • @NotThatGood, did you get this working?
    – carusot42
    Oct 13, 2017 at 17:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.