1

I just upgrade from Ubuntu Gnome 17.04 to 17.10, I have 2 monitors, the laptop that have a max resolution of 3200x1800 and a the secondary that have a max resolution of 1920x1080.

In other ubuntu versions I was unable to match this 2 resolutions, so my solution was to change the laptop resolution to 1920x1080 and it works.

But with this new update I'm unable to change the laptop resolution very time I try I get logged out from the session and when I enter again I have the same 3200x1080 resolution, I test this with Xorg and wayland.

  • What's your question? What are you trying to achieve? Could you please edit your question to add the output of xrandr to it (in an X.org session)? Thanks. – David Foerster Oct 20 '17 at 8:12
2

Using arandr (Graphical interface for xrandr) you can do it easily.

1) You need to install it:

sudo apt install arandr

2) Configure your schema: enter image description here

3) Save your schema (it will saved into ~/.screenlayout folder).

4) If arandr couldn't set 1920x1080 for you, open the file you saved (use gedit, nano or other text-based editor to change values. Do it and save;

#!/bin/sh
xrandr --output VGA-1 --mode 1280x1024 --pos 1920x0 --rotate left --output DVI-D-1-1 --off --output VGA-1-1 --off --output DVI-0 --primary --mode 1920x1080 --pos 0x0 --rotate normal --output HDMI-0 --off

5) Add this script to ~/.config/autostart/arandr.desktop file:

[Desktop Entry]
Name=arandr.desktop
GenericName="Monitor Schema"
Comment="Script to automatic set resolution"
Exec=/home/<user>/.screenlayout/<file>.sh
Terminal=false
Type=Application
X-Gnome-Autostart=true

6) chmod +x ~/.config/autostart/arandr.desktop to enable it to be executed.

  [1]: https://i.stack.imgur.com/Un9sM.png

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.