Ubuntu trial on bootable usb mode works fine, but after doing full installation and then removing the USB as i was instructed to, I get the following error after being stuck in loading screen after choosing Ubuntu in grub :

end kernel panic - not syncing: VFS: unable to mount root fs pn unknown block (0,0)"

I am using msi laptop with Nvidia drivers.

  • Please help us help you by telling us the brand name and model of the computer, graphics chip/card and wifi chip/card. Did the installation work well? Does it work well, if you select 'Try Ubuntu'? Which version of Ubuntu have you installed?
    – sudodus
    Commented Oct 11, 2017 at 18:53
  • Hello sir! I have a laptop from MSI. Model: GP60 2PE-225NE. The GPU is Nvidia GeForce GT 840M. I am not sure if this is the wifi card, since it is called wifi controller on the site that I am on, but the wifi controller is Intel 3160 Wilkins Peak 1. It is also 8 gb ram and intel core i7. and "Try Ubuntu" also works relatively wel
    – Daniel
    Commented Oct 11, 2017 at 19:17
  • The installation was smooth w/o any errors l, and I chose to check the box with install third party programs, and I also deleted windows and my old files, so that only Ubuntu is running. When creating the bootable USB I chose the newest ubuntu version 16.04 on Ubuntus website under Ubuntu Desktop. And terminal lists the following as the linux image version: ii linux-image-4.10.0-28-generic 4.10.0-28.32~16.04.2 amd64 Linux kernel image for version 4.10.0 on 64 bit x86 SMP Thanks for taking the time to answer my thread.
    – Daniel
    Commented Oct 11, 2017 at 19:20
  • I would try to install without any third party programs, and to install them afterwards, if necessary. You can expect problems with the graphics driver. Try with the boot option nomodeset, and if that helps, try to install an nvidia proprietary driver. If you still get kernel panic, there is some other problem, and I would suggest that you try another version of Ubuntu (with another version of the linux kernel and its hardware drivers), for example 'Artful' to be released as 17.10 during this month.
    – sudodus
    Commented Oct 12, 2017 at 6:07
  • I tried without any third party programs and got stuck on purple screen. Solutions I found suggested to install them with installation, but thanks mate.
    – Daniel
    Commented Oct 12, 2017 at 7:01

3 Answers 3


Do you have dual boot? Do you have grub installed? have you tried booting another kernel version? or safe mode?

have you tried using google?

Kernel Panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

I would say this is similar, but an older version of your question.

the mentioned topic should help you, but some CLI experience might be handy.

  • You could flag this question as a duplicate of that older question.
    – sudodus
    Commented Oct 11, 2017 at 18:30
  • Thanks for taking the time to answer. First of, no I installed and chose the option that deletes windows and all files, and I also allowed to install the 3rd party programs that come along with ubuntu, and I also have grub, i get the startup menu and after choosing ubuntu from grub it goes to purple screen and then the mentioned error . Yes I have googled it, but I couldn't find a solution myself. And I am also a novice at this, so I don't have any CLI experience either sadly.
    – Daniel
    Commented Oct 11, 2017 at 18:31
  • This is the exact error I receive. imgur.com/a/VRwvq
    – Daniel
    Commented Oct 11, 2017 at 18:39

First, you can try this :

The boot from livecd option and try using the terminal to fix your installation. Instructions in this link : https://askubuntu.com/a/48516/395498

although this is for an older version, i think if it was me, i would give it a go, just because the installation is already broken, this might fix it.

if this fails, or produces more faults, have you tried reinstalling? since you already deleted the entire harddrive, this might be your quickest option. i first would try to repair it using the topic provided, you can copy the link to a usb drive, when booted from live cd you can copy and past the link into your browser.


Actually I had the same issue and I have not identified the solution yet, I may have found the work around for that.I installed ubuntu in a dual boot configuration from a bootable USB stick which I have created using GPT partition scheme. I got the above error. Then I tried to create a bootable USB drive using MBR partition scheme and tried to install it now.I was able to install and boot it without any error in legacy mode.In my laptop,Windows uses UEFI mode and Ubuntu uses legacy boot mode. Although this may not be a perfect solution to your question, this can be a nice workaround for someone like me who cannot boot using UEFI.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .