4

I had installed keepassxc via snap, it worked fine but suddenly I get this error when I want to start it:

udev_enumerate_scan failed

thats the only error line, nothing else. I didnt find very much about that on stack or in other internet, just that it seems to have to do with snap rather than keepassxc.

xubuntu 16.04

2

The error most likely stems from the recent kernel update. I think there are two workarounds. In both cases you can first remove the keepassxc snap package with: sudo snap remove keepassxc

Then, either install the unofficial debian package (this is suggested in the open issue on GitHub: https://github.com/keepassxreboot/keepassxc/issues/1058)

Or, download the official AppImage. (Before running the AppImage, you have to make it executable: either by Right-Clicking on it, then Properties -> Permissions and checking "Allow executing file as program", or with command: chmod a+x KeePassXC-2.2.1-x86_64.AppImage See here for more info on AppImages: https://appimage.org/)

  • the inofficial deb packages are here to find: github.com/magkopian/keepassxc-debian/releases – Jeno Oct 12 '17 at 17:27
  • I have just given it a try and the snap package is running again on my machine. – rodolfo912 Oct 14 '17 at 7:39
  • is there any advantages to use snap instead of custom deb? – Jeno Oct 14 '17 at 8:13
  • I am not an expert on this. I have chosen snap in the first place because the deb package is called unofficial -- even though it should be as secure because it is open source and in use for quite some time. Plus, snap should be easier to (un)install and everything, including the dependencies, is stored at one place. All in all, I think it does not make much of a difference. – rodolfo912 Oct 14 '17 at 16:15
  • I'm also a Xubuntu 16.04 user and I do not recommend the snap version, I has a few problems editing entries (I couldn't write the database once I saved my passwords) and also it doesn't support browser integration, which is fundamental for daily use. The ppa worked just fine and it's the easiest way to install it in my opinion. sudo add-apt-repository ppa:phoerious/keepassxc sudo apt update sudo apt install keepassxc – kaenovsky Mar 13 '18 at 15:54
0

The fixing of the udev_enumerate error was worked on in the snap forum at https://forum.snapcraft.io/t/weird-udev-enumerate-error/2360 (in case you want to know what was wrong or how it got fixed)

protected by Community Oct 15 '17 at 23:43

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.