3

After I upgraded to Ubuntu 17.10, some icons are missing from the top bar.

For example, I have been using clipit for quite sometime. Previously, once launched, a icon appeared in the top bar allowing one to access the clipboard at the click of a mouse. However, after upgrade to Ubuntu 17.10, the icon is no longer appearing in the top bar.

Clipit is among my applications at startup.

enter image description here

And also, clipit is definitely running.

masroor@masroor-HP-ProDesk-400:~$ ps -axu | grep clipit
masroor   2303  0.2  0.2 583160 23976 tty2     Sl+  07:59   0:22 clipit
masroor   9476  0.0  0.0  14696  1088 pts/1    S+   10:49   0:00 grep --  color=auto clipit

The other icons like language indicators for keyboard are also missing.

Could you please tell me how can I make the icons reappear in my top bar?

  • Purge it, then try to install it from Official Repository using sudo apt install clipit, if you used Sourceforge version or vice versa, HTH... – Olimjon Oct 11 '17 at 5:30
  • If I'm not mistaken system tray icon are not visible in GNOME shell v3.26. You may try using TopIcons Plus. If the extension from extensions.gnome.org does not work under GNOME 3.26, try to install manually from the github page. – pomsky Oct 11 '17 at 11:37
  • @Olimjon That did not help. Thanks anyway. – Masroor Oct 12 '17 at 15:43
  • @pomsky That did it. Can not thank you enough. Do you want to convert your comment to a full answer with relevant explanations so that I can upvote and accept it? – Masroor Oct 13 '17 at 4:26
  • 1
    @Masroor It's really nice that you changed the title and description to state the missing app icons issue in general instead of making it a clipit-only issue. Now people who are having the same/similar problem would find this question easily and be able to try the solution(s). Also we can mark new questions having the same issue as its duplicates. – pomsky Oct 19 '17 at 20:23
5

The gnome-tweak-tool can be used to make the top icons reappear.

Install gnome-tweak-tool if not already installed.

$ sudo apt-get install gnome-tweak-tool

Launch it (gnome-tweak-tool from command line, Tweaks if from dock).

Select Extensions from the left menu. As we can see, Ubuntu appindicators is turned off. (You may also want to note that Ubuntu dock is turned off as well.)

enter image description here

Turn Ubuntu appindicators on. If you want, you may also turn on Ubuntu dock.

enter image description here

The top icon(s) reappear.

enter image description here

And if you turned on Ubuntu dock, the dock is also permanently displayed at left.

|improve this answer|||||
  • I reckon as you upgraded to 17.10 from an earlier release, Ubuntu Dock and AppIndicators were disabled. Those two if I'm not mistaken are activated by default in a fresh installation of Ubuntu 17.10. Also according to some reports AppIndicators fails to show indicators of some electron based applications like Skype, Slack etc. – pomsky Oct 15 '17 at 0:52
  • @pomsky About the first point, yes, you are right. I upgraded from an earlier release. About the second point, this happened in all three of my machines. I don't remember explicitly disabling these, rather they were always visible. So, I can not make any comment whether you are right or wrong. But again, may be I am missing something. – Masroor Oct 15 '17 at 2:25
  • Anyway I'm glad there's a simple solution like this. I'm pretty sure this is going to help many people who will upgrade to 17.10. – pomsky Oct 15 '17 at 2:30
  • @pomsky Thanks! That explains why it doesn't show Discord or Chrome. – Nonny Moose Jan 22 '18 at 0:19
3

In the last few versions of GNOME 3, application icons which use system tray (in particular Clipit icon) used to appear in an auto-hiding tray (called Legacy Tray) at the bottom left corner of the screen. But this feature is completely removed in GNOME shell v3.26 (the one shipped with Ubuntu 17.10) and the icon is invisible by default.

As a workaround you may try using a GNOME shell extension called TopIcons Plus. This extension moves legacy tray icons to the top bar and also provides some more customisations.

If the extension from the GNOME extensions website does not work under GNOME 3.26, try to install manually from the extension's GitHub page.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.