I was playing around with Chrome Remote Desktop and after a restart of my Ubuntu Gnome 17.04 box, things got really weird. First, I was prompted for a second entry of my password. Then, all my Google Chrome extensions were reset. And, finally, I noticed that I had no sound whatsoever.

After digging around in the audio settings, I discovered the following:

enter image description here

It looks like the original sound output was switched over to Chrome Remote Desktop with no option to reset it. Overall my computer felt like I was logged into a guest setting.

How the heck do I fix this?

7 Answers 7


This is what I did to fix the same issue. This way you don't have to restart your machine:

sudo rm -rf ~/.config/chrome-remote-desktop
killall pulseaudio
pulseaudio --start
gnome-shell --replace

It was also affecting my Gnome Apps. I was mad because I spent hours thinking it was because of my Yubikey since it's a U2F/FIDO2 Security Key. So I made sure to be forceful. I hope this is a cure-all for some folks until Google can make some fixes, I sent a feedback report to them about this.

  • 4
    This guy is a life saver. Nov 23, 2018 at 6:48
  • 2
    I got very irritated when my gome-terminal would not start anymore and had not noticed the sound issues. Your remark on other Gnome Apps being affected was helpful!
    – alexurba
    Dec 1, 2018 at 13:13
  • You are seriously a god among men. No CTRL+ALT+T terminal hot key response. No audio devices except for Chrome Remote Desktop 'sink'. And it was asking for a duplicate key-ring password on every log-in. I was just about to reinstall ubuntu from scratch which takes me hours after configuring everything and reinstalling apps and cloning code repos. Thank you so so so much for saving me from having to go through all of that trouble from the bottom of my heart. I had no idea what was wrong with Ubuntu but I knew it was a serious configuration issue that I wouldn't be able to personally sort out. Jan 1, 2019 at 20:52
  • this: killall pulseaudio pulseaduio --start is enough for 16.04 with unity
    – ses
    Jan 16, 2019 at 18:23
  • Thanks so much - I didn't know what was the issue initially was but this thread helped me identity and resolve it. May 13, 2019 at 4:07

There is some problem with Chrome Remote Desktop with Ubuntu. To get your system sound back for all applications you should remove the extension from both Chrome and Ubuntu.

Run the following command:

sudo apt-get remove chrome-remote-desktop

and restart Ubuntu.

  • 3
    thank you! Works perfectly. I just wish I would've found this 3 hours ago :( derp. Apr 19, 2019 at 21:46
  • 1
    use purge instead of remove to uninstall the package completely. Aug 12, 2019 at 8:01

Somehow I manage to make the audio work in Ubuntu 18.04 with Chrome Remote Desktop still installed, by creating file .chrome-remote-desktop-session in user folder

cd ~
touch .chrome-remote-desktop-session

and put this lines to the file

DESKTOP_SESSION=ubuntu XDG_CURRENT_DESKTOP=Unity /usr/sbin/lightdm-session 'gnome-session --session=ubuntu'

I don't know if restarting ubuntu is required or not, but I realize this works after reboot

Ref: https://bugs.chromium.org/p/chromium/issues/detail?id=496885

  • This worked very well for me. Even the gnome-terminal started showing up again.
    – shaoyl85
    Dec 3, 2018 at 23:45
  • Worked for me, using ubuntu 18.04. Aug 9, 2019 at 22:04

I found that by removing (rather, renaming) the ~/.config/chrome-remote-desktop directory and restarting, my sound defaulted to the standard line out.


I used this command to refresh the devices.

pacmd unload-module module-udev-detect && pacmd load-module module-udev-detect

It did the job, the sound test worked. Although, I was still not able to hear the sound in Chrome (YouTube or Hangouts, for example).

At least for now I ended up uninstalling Chrome remote desktop from my machine.


if you are disappointed in Chrome Remote Desktop app and want to uninstall it try these steps:

Uninstall New App

  1. open new Chrome tab and navigate to chrome://apps
  2. find Chrome Remote Desktop app there
  3. right-click
  4. select Remove from Chrome
  5. A message may appear asking if you want to remove the app. Click Remove.

(source: https://support.google.com/chrome_webstore/answer/1053346?hl=en)

Uninstall Old App

  1. Open Terminal
  2. sudo apt purge chrome-remote-desktop
  3. sudo apt autoremove

So, I was looking at the sound settings again and found a link to the chrome-remote-desktop in the output, which I had not previously seen.

I ran:

sudo rm -rf ~/.config/chrome-remote-desktop
killall pulseaudio
pulseaudio --start
gnome-shell --replace

Sound has been working through the built-in speakers in all the apps I want.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.