1

I've been trying to install Ubuntu 17.04 to an Acer Aspire E17 using a USB flash drive. The laptop contains 2 drives: an SSD which has Windows 10 installed and bears an EFI Partition as well as the Windows System Partition and some Windows recovery partition and an HDD which contains one NTFS partition for data. The goal is to set up a working dual-boot.

Prior to installing Ubuntu, I performed the following steps:

  1. I disabled the fast startup of Windows in order to be able to access the NTFS partitions from Ubuntu
  2. Disabled secure boot in the UEFI menu
  3. Changed the boot order and moved the USB FDD to the first position

After performing these steps, booting from the a USB flash drive did not work but I managed to get into the UEFI boot manager by pressing F12 on startup and was able to select the drive and boot the live system.

Then I tried to install Ubuntu. I selected the option to partition the drives myself and I created the following partitions:

On the SSD I did not change anything. On the HDD, I resized the NFTS partition to a third of the drive size and created two additional ext4 partitions, one as root-partition (mount point /) and one as home partition (mount point /home). I also had to select where the bootloader should be placed and I selected it to be placed on the HDD. The installation process started and everything worked as expected. After it was finished, a dialog appeared which stated that the computer needs to be rebooted. I selected the option to reboot now and Ubuntu shut down properly and I even got a message to remove the installation drive and shut press "Enter" after doing so. OK, so now the computer performed a reboot and Windows started. I rebooted manually again and entered the UEFI boot menu which unfortunately only showed the Windows Boot Manager.

So eventually I repeated the whole installation process, but this time I selected the bootloader to be installed to the SSD drive, while using exactly the same partitions like in the first attempt. The installtion process also completed successfully. Now this time, after selecting the option to reboot in the dialog, the screen went black and displayed some error messages, among them the words "failed to claim device" and "plaform device creation failed". I'm afraid I did not write the exact message down, sorry, but from what I could google so far this might be a driver issue. Anyhow, the black screen would not disappear for minutes so I eventually shut the computer down and tried to reboot, but of course, also this time there was no Ubuntu entry in the UEFI boot menu.

I've once had the experience with a (different) black screen error message after installing on another computer (also with a SSD) and after waiting for a very long amount of time, the installation process somehow finished successfully.

Since the laptop in question is not my own I did not have the option to wait that long and next time I will have access to it will be on Thursday.

Before trying any new experiments I wanted to ask whether my partition table is legit and where to put the bootloader. Should I maybe try to install Ubuntu on the SSD since the EFI partition is also there? Did I go wrong anywhere?

1

Turned out that the Acer UEFI will just not display a boot entry for Ubuntu automatically, regardless of whether there is Windows installed or not.

Found the answer on this page: https://wiki.ubuntuusers.de/EFI_Problembehebung/#Acer-Rechner (it's in German)

Installing the bootloader to the HDD worked fine and I installed 17.10, worked perfectly fine!

0
I also had to select where the bootloader should be placed and I selected it to be placed on the HDD. 

In that case you'd have two boot loaders. Windows boot loader in the SSD, and Ubuntu boot loader in the HDD. So once installed, to switch into Ubuntu bootloader you could have simply use the EFI boot menu F12.

If you want to override existing EFI partition on the SSD, you should set ssd as the Device for boot loader installation in the installer.

Either way it should work. Just re-install.

8
  • As pointed out in my first post, after selecting the boot loader to be placed on the HDD did not work, i.e., Ubuntu did not appear in the UEFI boot menu. – Christina Marinica Oct 10 '17 at 12:05
  • I mean change the boot device from SDD to HDD. – Gayan Weerakutti Oct 10 '17 at 12:07
  • I'm sorry, I don't get what you mean with the last comment? – Christina Marinica Oct 10 '17 at 12:13
  • In BIOS you could change the boot order priority, right? So I mean you should have selected HDD as the first priority. – Gayan Weerakutti Oct 10 '17 at 12:18
  • Thanks for clarifying. So you mean I should try to re-install the boot loader to the HDD and then set the HDD to be the first in boot order? Or to do that before installing it? Anyhow I need to add that after installing the bootloader to the HDD I actually checked out the boot priority in the BIOS settings and there was also no Ubuntu entry, but the Windows Entry. How it is possible that there is no Ubuntu entry anywhere? – Christina Marinica Oct 10 '17 at 12:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.