1

I originally had Windows10 installed on my laptop.

I did partitioning, installed Ubuntu 14.04, had a low-graphics mode problem but couldn't solve it and then tried to reinstall Ubuntu.

In this process, I think I have erased the Windows10 and have instead installed Ubuntu, again.

When I log in to Ubuntu, I see two disks, each with /boot folder in it. And the below is the information of my partitioning:

Disk /dev/sda: 2000.4 GB, 2000398934016 bytes
255 heads, 63 sectors/track, 243201 cylinders, total 3907029168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x000e299b

Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2046  3906437119  1953217537    5  Extended
Partition 1 does not start on physical sector boundary.
/dev/sda5            2048     7999487     3998720   82  Linux swap / Solaris
/dev/sda6         8001536   398620671   195309568   83  Linux
/dev/sda7       398626816  3906437119  1753905152   83  Linux

Disk /dev/sdb: 256.1 GB, 256060514304 bytes
255 heads, 63 sectors/track, 31130 cylinders, total 500118192 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0f838f59

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *        2048   498127989   249062971    7  HPFS/NTFS/exFAT
/dev/sdb2       498128896   500115455      993280   27  Hidden NTFS WinRE

Is my understanding of partitioning correct? That is, is the Windows deleted?

If so, is there a way for me to fix the problem having two partitioned Linux system and make it into one?

Any answer would be helpful. Thanks.

  • /dev/sdb1 seems to be a Windows partition. Try to mount it and check if ti is your lost Windows. – Soren A Jun 27 '18 at 13:58
-1

I see that there is an NTFS partition. If you see two disks and you have only one disk that means there is a partitioning problem on the OS just sees it like that. Anyway, the NTFS partition means that there is Windows 10 or the partition has at least part of it. Either way, try booting up to Windows 10. Go to the boot menu in your system. If Windows 10 is there, you haven't deleted it. Or else if it's not there, you've deleted the partition (or Windows 10 is corrupt or having a problem.)

From my view, you have a laptop and there is a partitioning error seen by the OS you are using or there is a HDD error in the disk. Little information is found about this problem. /dev/sdb means there is a second disk. If this is an error, I don't think you can fix it unless you reformat the hard disk (or any other storage device) and reinstall Windows 10 and Ubuntu 14.04. (If you decide to do this, make sure to do a complete backup.) Another solution is to get another HDD/SSD and reinstall Windows 10 and Ubuntu.

GParted can help you to reformat the disk. Make sure to burn it to a CD or make a bootable flash drive with it. Some suggested software is Etcher and GNOME disks (Sometimes GNOME disks comes with your Ubuntu installation, or you have to install it via command line.) Then boot it up on your computer.

Alternately (and risky,) if the same error happens, you reinstall Ubuntu (I know you have installed it 2 times,) from CD or USB (Do not use Reset Ubuntu 14.04 to Factory settings in GRUB) and during the installation, choose Something else and select the Linux partition and wipe it out. During the process Windows 10 may become unbootable, but if you want to take the risk, do it.

Make both partitions LVM (Logical Volume Manager) partitions (I mean sda and sdb.) Then they may merge together and make one disk: sda. See this link: How To Merge Multiple Hard Drives- Unix And Linux. Once you've done this, if Windows does not boot up, reinstall Windows. I hope you did a backup before doing all this. If this helped, let me know.

-Linuhackz

| improve this answer | |
  • 1
    Check out the website, you'll see the answer. – Super Mustang Y.T. Jun 27 '18 at 13:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.