2

After installing it seemed to work fine for about a month, but then suddenly on a reboot it didn't turn on.

I had installed the driver by this method.

A similar problem seems to have been encountered by others here.

The fix listed didn't work for me though. I followed the instructions as follows:

I first opened both dkms.conf files:

sudo -H mousepad /usr/src/rtl8812au-4.3.8.12175.20140902+dfsg/dkms.conf
sudo -H mousepad /var/lib/dkms/rtl8812au/4.3.8.12175.20140902+dfsg/build/dkms.conf

Then I edited the fourth line of each so that it reads:

MAKE="'make' all KVER=${kernelver}"

Finally I tried to run dkms build:

sudo dkms build rtl8812au/4.3.8.12175.20140902+dfsg -k $(uname -r)

Which is when it outputs the following:

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area....
'make' all KVER=4.10.0-35-generic........(bad exit status: 2)
ERROR: Cannot create report: [Errno 17] File exists: 
'/var/crash/rtl8812au-dkms.0.crash'
Error! Bad return status for module build on kernel: 4.10.0-35-generic 
(x86_64)
Consult /var/lib/dkms/rtl8812au/4.3.8.12175.20140902+dfsg/build/make.log for more information.

Details

Software and Updates currently reads like this.

lsusb shows that it is a recognized device:

Bus 001 Device 004: ID 13b1:003f Linksys WUSB6300 802.11a/b/g/n/ac 
Wireless Adapter [Realtek RTL8812AU]

When I run:

sudo lshw -C network

I get the following:

*-network               
   description: Ethernet interface
   product: 82579V Gigabit Network Connection
   vendor: Intel Corporation
   physical id: 19
   bus info: pci@0000:00:19.0
   logical name: enp0s25
   version: 05
   serial: 00:22:4d:51:9b:2e
   size: 1Gbit/s
   capacity: 1Gbit/s
   width: 32 bits
   clock: 33MHz
   capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k duplex=full firmware=0.11-4 ip=192.168.0.194 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
   resources: irq:35 memory:f3400000-f341ffff memory:f3425000-f3425fff ioport:3040(size=32)

dkms status gives me the following

dkms status
bbswitch, 0.8, 4.10.0-28-generic, x86_64: installed
bbswitch, 0.8, 4.10.0-32-generic, x86_64: installed
bbswitch, 0.8, 4.10.0-33-generic, x86_64: installed
bbswitch, 0.8, 4.10.0-35-generic, x86_64: installed
bbswitch, 0.8, 4.10.0-37-generic, x86_64: installed
bbswitch, 0.8, 4.4.0-93-generic, x86_64: installed
bbswitch, 0.8, 4.4.0-96-generic, x86_64: installed
nvidia-384, 384.90, 4.10.0-35-generic, x86_64: installed
nvidia-384, 384.90, 4.10.0-37-generic, x86_64: installed
rtl8812au, 4.3.8.12175.20140902+dfsg: added

Can anyone give me a hand? I'm sort of at a loss here.

Thank you so much in advance! If there is any other info I need to share to figure out a fix, please let me know.

5
  • Did you edit the dkms.conf file as suggested and then try again?
    – chili555
    Oct 10 '17 at 4:10
  • Yes I did. I followed the instructions on the question I linked as written. I'll include my steps above. :)
    – classl3ss
    Oct 10 '17 at 11:32
  • I made edits which explains the steps I took. Thanks for getting the conversation started chili555
    – classl3ss
    Oct 10 '17 at 11:46
  • Please edit to include results for dkms status
    – Jeremy31
    Oct 10 '17 at 14:40
  • You'll probably want to start with the rtl8812au 4.3.14 version of this driver, make the dkms.conf mods, and then try the dkms add/build/install again. Get the source at github.com/diederikdehaas/rtl8812AU and make sure to click on the 4.3.14 link. Delete the "/var/crash/rtl8812au-dkms.0.crash" by hand.
    – heynnema
    Oct 11 '17 at 3:20
2

The rtl8812au source code from https://github.com/scrivy/rtl8812AU_8821AU_linux is not patched for the 4.10 kernels. You can either go back to using the 4.4 kernels or install rtl8812au-dkms patched for Ubuntu 17.10 after removing the version you have with

code>cd rtl8812AU_8821AU_linux
sudo make uninstall
sudo dkms remove rtl8812au/4.3.8.12175.20140902+dfsg --all
sudo rm -r /usr/src/rtl8812au-4.3.8.12175.20140902+dfsg
sudo rm -r /var/lib/dkms/rtl8812au
Then you can download from https://packages.ubuntu.com/artful/rtl8812au-dkms Most browsers will put the file in the Downloads folder and it can be installed by
cd Downloads
sudo dpkg -i rtl8812au-dkms
You will likely need to make the changes to dkms.conf so it will build against the correct kernel when a kernel update occurs. You could also use another github source and you shouldn't have to edit the dkms.conf file
git clone https://github.com/abperiasamy/rtl8812AU_8821AU_linux.git
cd rtl8812AU_8821AU_linux
sudo make -f Makefile.dkms install
Reboot

5
  • Jeremy31, thanks for your comment/help. However, the output is that "Package 'rtl8812au-dkms' is not installed, so not removed". When I tried the variation, sudo apt-get remove rtl8812au, the output is "Unable to locate package rtl8812au". Is there another method of uninstall that might work?
    – classl3ss
    Oct 11 '17 at 15:17
  • @classl3ss to see what/if package you installed, do a dpkg -l *8812* | grep ii. Also note my comment above that calls out a newer version of the driver than you have, or the one that @Jeremy31 refers to (which is the same as your version).
    – heynnema
    Oct 11 '17 at 19:58
  • Thank you for continuing to deal with this with me everyone. There seems to be something weird about my install, in that I cannot seem to actually uninstall it. When the non-functioning driver is disabled dpkg -l 8812 | grep ii gives me this output>dpkg-query: no packages found matching 8812. Also, when I try to run "sudo dkms remove rtl8812au/4.3.8.12175.20140902+dfsg --all" it gives me this output>Error! There are no instances of module: rtl8812au 4.3.8.12175.20140902+dfsg located in the DKMS tree.
    – classl3ss
    Oct 15 '17 at 2:06
  • Regardless, the driver still appears under Additional Drivers, and I cannot seem to get a clean uninstall so I can install from scratch. What else can I try?
    – classl3ss
    Oct 15 '17 at 2:09
  • This worked, but I had to disable secure boot so that the unsigned kernel modules can be loaded.
    – Étienne
    Feb 18 '19 at 16:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.