9

I installed Packet Tracer 7.1 using command lines. It installed fine but when I type packettracer it just says

starting packettracer 7.1

but doesn't work. I tried every solution I found on the internet but they didn't work.

  • What commands did you use to install? – rplaughlin Oct 9 '17 at 23:45
  • I opened terminal in the folder and typed "./install" it installed , it even said " installation successful .. – Stoufa Gheribi Oct 10 '17 at 14:20
  • I don't claim to be an expert on packettracer, and I'm not one, but it sounds like you might want to try installing from somewhere else. Is it available in the apt repositories? You could try uninstalling your current installation and installing through apt. – rplaughlin Oct 10 '17 at 21:27
8

I was able to run Cisco Packet Tracer 7.1 on Ubuntu 16.04 by doing the following:

1-Cisco Packet Tracer 7.1 requires an older version of a package not present on Ubuntu 16.04 so you need to get it by typing

wget http://security.ubuntu.com/ubuntu/pool/main/i/icu/libicu52_52.1-3ubuntu0.7_amd64.deb

2- To install the package you just downloaded type

sudo dpkg -i libicu52_52.1-3ubuntu0.7_amd64.deb

3- Verify proper installation using this commands

sudo updatedb; locate libicui18n

Check for the following packages to be installed:

  • /usr/lib/x86_64-linux-gnu/libicui18n.so.52

  • /usr/lib/x86_64-linux-gnu/libicui18n.so.52.1

Those are the packages needed by Cisco Packet Tracer to work properly.

Now you can type packettracer on terminal and the program should start.

3

Navigate to the directory where PacketTracer is installed (this is the default):

cd /opt/pt/bin

then run PacketTracer7

./PacketTracer7

Now, if it shows a list of "libqt5xxx" missing libraries, please install them all.

sudo apt install libqt5xxx*

Remember, just write everything that is behind the first "."(dot) and to put the * in the end of the name of the package.

In my case, it was a package named "libQt5Script.so.5", so I did this:

sudo apt-get install libqt5script*

After that, running PacketTracer7

./PacketTracer7

should now work.

  • I modified the tpl.linguist and tpl.packettracer. On the line with PTDIR=III, I changed it to PTDIR=/opt/pt. And after that I did what this answer says. Thank you – Rosário Pereira Fernandes Nov 6 '17 at 18:46
  • Using your method, I figured out that I have to install libqt5webkit5, libqt5xml5 and libqt5script* to make Packet Tracer 7.1.1 run on Ubuntu 17.10 – user3405291 May 3 '18 at 10:53
1

If you check out the libraries required by using this command:

cd /opt/pt/bin
ldd Packettracer7

you'll see all the libraries inclunding the missing ones
So to solve this problem just copy the library missing like :

sudo cp /opt/pt/lib/libname /usr/lib/x86_64-linux-gnu

And ta da!!!
Problem solved

1

i fixed this by

wget http://ftp.br.debian.org/debian/pool/main/i/icu/libicu52_52.1-8+deb8u6_amd64.deb

then this command line

sudo dpkg -i libicu52_52.1-8+deb8u6_amd64.deb

and finally

packettracer

0

There is a known issue between packet tracer 7.1 and Ubuntu 16.04 which blocks packet tracer from starting. Packet tracer needs a library libicui18n.so.52 which has been updated with libicui18n.so.55 in Ubuntu 16.04. To solve this issue, we have to download and install the older version of this library. Older version of this library is available in a Debian package at :-

http://security.ubuntu.com/ubuntu/pool/main/i/icu/libicu52_52.1-3ubuntu0.7_amd64.deb.

Run following commands to download and install this package

wget http://security.ubuntu.com/ubuntu/pool/main/i/icu/libicu52_52.1-3ubuntu0.7_amd64.deb
sudo dpkg –i libicu52_52.1-3ubuntu0.7_amd64.deb
sudo updatedb

Once package is installed, run following command to update the library path

LD_LIBRARY_PATH=/opt/pt/lib /opt/pt/bin/PacketTracer7

Source :- https://www.computernetworkingnotes.com/ccna-online-training/download-packet-tracer-for-windows-and-linux.html

0

Open terminal type packettracer, make sure you use two t's, packettracer not packetracer, not case sensitive, do not need to change directory, I am running version 7.1.1 on ubuntu 14.04, no need to type packettracer7 or packettracer7.1.1 just packettracer.

My Packettracer program in /opt/pt where it is installed is named packettracer.

protected by Community Apr 11 '18 at 7:50

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.