So I have recently installed Ubuntu 11.10 for a dual boot with wind 7.

After the install I had like 300 updates, so I installed them. At first I could use the internet, although it was extremely slow. However now I cannot, sometimes it will load and others it will simply time out.

When I try to download something it will either take forever or will not at all. This is a wired system. On Windows side my speeds are fine. Any help would be greatly appreciated.

Also like I said I am new to Linux/Ubuntu so please be nice.

One last thing, I also installed 11.10 for same dual boot on my laptop, and wireless speed is the same as on Windows? Only the wired desktop gives me the problem?

Hear is some hardware info.. Hope it helps.

Mobo: Gigabyte GA=880GMA- AMD / CPU: AMD Phenom (tm) IIx4 965 / 16 GB Ram / Realtek PCIe GBE Family Controller / Cisco Linksys E2000 /

Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06) /

eth0 Link encap:Ethernet HWaddr 50:e5:49:33:64:cf
inet addr: Bcast: Mask: inet6 addr: fe80::52e5:49ff:fe33:64cf/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:76722 errors:0 dropped:76722 overruns:0 frame:76722 TX packets:49692 errors:0 dropped:65 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:107956638 (107.9 MB) TX bytes:4342553 (4.3 MB) Interrupt:44 Base address:0x2000

thanks to roadmr problem solved! I powered down PC, un plugged power from pc end, waited a few (maybe 3)minutes. plugged power back in, pushed and held power button for 30 + seconds. Let go, powered on PC, and my Internet is fine! downloads and web speed blaze, just like on my Win 7 boot, maybe even faster. Problem Solved, Thanks to all!! **


Your ethernet chipset (RTL8168) is known to cause problems in Ubuntu, which tries to use the RTL8169 driver, which is somewhat compatible in theory, but in practice produces bad performance like what you're experiencing.

See this question for a discussion:

Slow wired internet connection on Realtek RTL8168-8111 (Rev 6)

This blog post has a way to install the proper RTL8168 driver, it's from 2009 so it could potentially be out of date:


| improve this answer | |
  • Thanks a Mill!! I read your first link, in that link i did what the 2nd and 3rd answer said to do, simply powered down, unplugged my PC for a few min, pluged back up, pushed power button for 30 sec, let go, powered on, and know ubuntu Internet is blazing fast, just as is my win 7!! thank you so much!! – user42424 Jan 20 '12 at 18:37

My guess is that your system is downloading some updates. Run gnome-systtem-monitor and see what is your network utilization.

If you expect some hardware problems with your ethernet card, see output of dmesg | grep eth0.

Also, good experiment is to boot from liveCD (like ubuntu installer) and see how it works from it.

| improve this answer | |
  • when i did system monitor, there is nothing at all going on, when i did grep eth0 i get tons of eth0: link up ? I found these drivers but not sure wich to use. realtek.com.tw/downloads/… im about to reboot live cd right now. – user42424 Jan 20 '12 at 16:24
  • Booting from live cd (i did option use ubuntu without install) internet is still in snail mode, most the time i get cannot display, but after a few tries i will actually get the web page.? – user42424 Jan 20 '12 at 16:43
  • If you dont see any wird erros from dmes, I guess it's your network configuration (i.e. your router). Do you get same IP from DHCP when booting from ubuntu and windows? – Michał Šrajer Jan 20 '12 at 16:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.