0

I had windows 10 and ubuntu 17.04 dual-booting using easyBCD, working fine with no problems. I had to reinstall ubuntu due to package installation errors that I couldn't figure out how to fix, even with having tried to find answers in various ubuntu forums.

After re-installation of 17.04, GRUB works fine to boot both windows 10 and 17.04 (I use grub-customizer to hide extra options for ubuntu if that matters), easyBCD refuses to install correctly. I have tried making sure that the NST files are installed to my C: drive in windows, and have followed other directions but nothing seems to work.

My question is, it seems like Windows works fine and only has an issue when it is updating files for which it seems like it needs to control the bootloader (such as windows 10 cumulative updates, which is why I want easyBCD to work), otherwise other windows 10 updates work fine. Is my only option to figure out why easyBCD isn't working? I am pretty sure GRUB is installed in the MBR not in the partition itself, if that makes any difference. I can check that to make sure.

I dual-boot because my laptop refuses to allow me to virtualize, either in Ubuntu or Windows 10. If I could virtualize, I would do that instead as it seems to easier and more stable than dual-booting.

Thanks for any help. I can clarify my situation if necessary or provide additional information.

1

my laptop refuses to allow me to virtualize

Have you tried to enable virtualization in BIOS or UEFI?

Could you show hard drive partitioning from Windows : My computer (right click) -> Manage -> Storge?

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.